Skip to content
Laskyr

Plugins · petitioner · data as of 2026-11-04

Is Petitioner safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.8.7)

As of 2026-11-04. 1 issue is on record for older versions; version 0.7.4 or newer fixes all of them that state a fix.

Latest version
0.8.7
Last updated
2026-10-12
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Create, target, and track high-impact petitions with Petitioner: automate delivery to decision-makers, manage approvals, and export rich submission da … — by Anton Voytenko

What to do

  1. Update to the latest version (0.8.7). Anything older than 0.7.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get petitioner --field=version shows what you run; wp plugin update petitioner updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-32514 · published 2026-03-25

Missing authorization check in Petitioner (0.7.3 and older)

Affected
0.7.3 and older
Fixed in
0.7.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Anton Voytenko Petitioner petitioner allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Petitioner: from n/a through <= 0.7.3.

NVD CVE-2026-32514Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Petitioner vulnerability status badge
<a href="https://laskyr.com/plugins/petitioner"><img src="https://laskyr.com/plugins/petitioner/badge.svg" alt="Petitioner vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit