Skip to content
Laskyr

Plugins · persian-woocommerce-sms · data as of 2026-11-04

Is افزونه پیامک ووکامرس safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.3.3)

As of 2026-11-04. 8 issues are on record for older versions; version 7.3.2 or newer fixes all of them that state a fix.

Latest version
7.3.3
Last updated
2026-11-01
Active installs
50,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

افزونه جامع و حرفه ای برای اطلاع رسانی پیامکی وضعیت سفارشات و رویداد های محصولات ووکامرس — by PersianScript

What to do

  1. Update to the latest version (7.3.3). Anything older than 7.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get persian-woocommerce-sms --field=version shows what you run; wp plugin update persian-woocommerce-sms updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-111021 · published 2026-10-28

Reflected cross-site scripting (XSS) in افزونه پیامک ووکامرس (7.2.0 up to (not including) 7.3.2)

Affected
7.2.0 up to (not including) 7.3.2
Fixed in
7.3.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The افزونه پیامک ووکامرس | Persian WooCommerce SMS WordPress plugin before 7.3.2 does not sanitise and escape a parameter before reflecting it back into an HTML attribute, leading to Reflected Cross-Site Scripting that is executed in the browser session of a logged-in privileged user who is tricked into submitting a crafted cross-site request.

NVD CVE-2026-111021WPScan advisory

high 7.6 CVE-2026-65532 · published 2026-07-23

SQL injection in افزونه پیامک ووکامرس (7.2.2 and older)

Affected
7.2.2 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager SQL Injection in Persian Woocommerce SMS <= 7.2.2 versions.

NVD CVE-2026-65532Patchstack advisory

high 7.1 CVE-2026-22352 · published 2026-02-20

Reflected cross-site scripting (XSS) in افزونه پیامک ووکامرس (7.1.1 and older)

Affected
7.1.1 and older
Fixed in
7.2.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PersianScript Persian Woocommerce SMS persian-woocommerce-sms allows Reflected XSS.This issue affects Persian Woocommerce SMS: from n/a through <= 7.1.1.

NVD CVE-2026-22352Patchstack advisory

high 7.6 CVE-2025-49315 · published 2025-06-06

SQL injection in افزونه پیامک ووکامرس (7.0.10 and older)

Affected
7.0.10 and older
Fixed in
7.1.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in PersianScript Persian Woocommerce SMS persian-woocommerce-sms allows SQL Injection.This issue affects Persian Woocommerce SMS: from n/a through <= 7.0.10.

NVD CVE-2025-49315Patchstack advisory

high 7.1 CVE-2024-54312 · published 2024-12-13

Reflected cross-site scripting (XSS) in افزونه پیامک ووکامرس (7.0.5 and older)

Affected
7.0.5 and older
Fixed in
7.0.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PersianScript Persian Woocommerce SMS persian-woocommerce-sms allows Reflected XSS.This issue affects Persian Woocommerce SMS: from n/a through <= 7.0.5.

NVD CVE-2024-54312Patchstack advisory

medium 6.1 CVE-2024-10046 · published 2024-12-07

Reflected cross-site scripting (XSS) in افزونه پیامک ووکامرس (7.0.5 and older)

Affected
7.0.5 and older
Fixed in
7.0.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The افزونه پیامک ووکامرس Persian WooCommerce SMS plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 7.0.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-10046Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2024-9213 · published 2024-10-17

Reflected cross-site scripting (XSS) in افزونه پیامک ووکامرس (7.0.2 and older)

Affected
7.0.2 and older
Fixed in
7.0.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The افزونه پیامک ووکامرس Persian WooCommerce SMS plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 7.0.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9213Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2016-10987 · published 2019-09-17

Cross-site scripting (XSS) in افزونه پیامک ووکامرس (older than 3.3.4)

Affected
older than 3.3.4
Fixed in
3.3.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The persian-woocommerce-sms plugin before 3.3.4 for WordPress has ps_sms_numbers XSS.

NVD CVE-2016-10987wordpress.org0x62626262.wordpress.comwpvulndb.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
افزونه پیامک ووکامرس vulnerability status badge
<a href="https://laskyr.com/plugins/persian-woocommerce-sms"><img src="https://laskyr.com/plugins/persian-woocommerce-sms/badge.svg" alt="افزونه پیامک ووکامرس vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit