Skip to content
Laskyr

Plugins · peprodev-ups · data as of 2026-11-04

Is PeproDev Ultimate Profile Solutions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.3.0)

As of 2026-11-04. 4 issues are on record for older versions; version 8.2.37 or newer fixes all of them that state a fix.

Latest version
8.3.0
Last updated
2026-10-01
Active installs
70+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Profile builder, user dashboard and OTP/SMS/Google login and registration for WordPress, with WooCommerce, LearnDash and WPML support. — by Pepro Dev. Group

What to do

  1. Update to the latest version (8.3.0). Anything older than 8.2.37 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get peprodev-ups --field=version shows what you run; wp plugin update peprodev-ups updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4791 · published 2026-10-10

Stored cross-site scripting (XSS) in PeproDev Ultimate Profile Solutions (8.2.36 and older)

Affected
8.2.36 and older
Fixed in
8.2.37 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeproDev Ultimate Profile Solutions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `logout-url` shortcode's 'button' attribute in all versions up to, and including, 8.2.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4791Wordfence advisoryCode change (fix)Plugin source

high 8.2 CVE-2025-3921 · published 2025-05-07

Missing authorization check in PeproDev Ultimate Profile Solutions (1.9.1 to 7.5.2)

Affected
1.9.1 to 7.5.2
Fixed in
8.0.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeproDev Ultimate Profile Solutions plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the handel_ajax_req() function in versions 1.9.1 to 7.5.2. This makes it possible for unauthenticated attackers to update arbitrary user's metadata which can be leveraged to block an administrator from accessing their site when wp_capabilities is set to 0.

NVD CVE-2025-3921Wordfence advisorywordpress.orgPlugin source

medium 5.3 CVE-2025-3924 · published 2025-05-07

Missing authorization check in PeproDev Ultimate Profile Solutions (1.9.1 to 7.5.2)

Affected
1.9.1 to 7.5.2
Fixed in
8.0.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeproDev Ultimate Profile Solutions plugin for WordPress is vulnerable to unauthorized access of data via its publicly exposed reset-password endpoint. The plugin looks up the 'valid_email' value based solely on a supplied username parameter, without verifying that the requester is associated with that user account. This allows unauthenticated attackers to enumerate email addresses for any user, including administrators.

NVD CVE-2025-3924Wordfence advisorywordpress.orgPlugin source

critical 9.8 CVE-2025-3844 · published 2025-05-07

Authentication bypass in PeproDev Ultimate Profile Solutions (1.9.1 to 7.5.2)

Affected
1.9.1 to 7.5.2
Fixed in
8.0.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeproDev Ultimate Profile Solutions plugin for WordPress is vulnerable to Authentication Bypass in versions 1.9.1 to 7.5.2. This is due to handel_ajax_req() function not having proper restrictions on the change_user_meta functionality that makes it possible to set a OTP code and subsequently log in with that OTP code. This makes it possible for unauthenticated attackers to login as other users on the site, including administrators.

NVD CVE-2025-3844Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PeproDev Ultimate Profile Solutions vulnerability status badge
<a href="https://laskyr.com/plugins/peprodev-ups"><img src="https://laskyr.com/plugins/peprodev-ups/badge.svg" alt="PeproDev Ultimate Profile Solutions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit