Skip to content
Laskyr

Plugins · pepro-mapify · data as of 2026-11-04

Is PeproDev Branches Map (Mapify) safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.2)

As of 2026-11-04. 1 issue is on record for older versions; version 3.0.2 or newer fixes all of them that state a fix.

Latest version
3.0.2
Last updated
2026-10-09
Active installs
30+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Show your branches on OpenStreetMap, Google Maps, Mapbox, Persian maps or an offline map of Iran, with a searchable branches list. — by Pepro Dev. Group

What to do

  1. Update to the latest version (3.0.2). Anything older than 3.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pepro-mapify --field=version shows what you run; wp plugin update pepro-mapify updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-9373 · published 2026-10-14

Stored cross-site scripting (XSS) in PeproDev Branches Map (Mapify) (3.0.1 and older)

Affected
3.0.1 and older
Fixed in
3.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeproDev Branches Map plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 3.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9373Wordfence advisoryCode change (fix)wordpress.orggithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PeproDev Branches Map (Mapify) vulnerability status badge
<a href="https://laskyr.com/plugins/pepro-mapify"><img src="https://laskyr.com/plugins/pepro-mapify/badge.svg" alt="PeproDev Branches Map (Mapify) vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit