Skip to content
Laskyr

Plugins · peachpay-for-woocommerce · data as of 2026-11-04

Is PeachPay safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.121.1)

As of 2026-11-04. 6 issues are on record for older versions; version 1.120.70 or newer fixes all of them that state a fix.

Latest version
1.121.1
Last updated
2026-11-03
Active installs
300+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Connect ConvesioPay, Stripe, PayPal, Square, and more. Offer Express Checkout and reduce cart abandonment. — by peachpay

What to do

  1. Update to the latest version (1.121.1). Anything older than 1.120.70 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get peachpay-for-woocommerce --field=version shows what you run; wp plugin update peachpay-for-woocommerce updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-103376 · published 2026-10-17

Information disclosure in PeachPay (1.117.9 up to (not including) 1.120.70)

Affected
1.117.9 up to (not including) 1.120.70
Fixed in
1.120.70
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The PeachPay — Payments & Express Checkout for WooCommerce (supports Stripe, PayPal, Square, Authorize.net, NMI) WordPress plugin before 1.120.70 does not perform any capability or ownership check before returning an order's secret key in response to an unauthenticated request, allowing anyone to retrieve the key for any paid order and use it to view that order's customer name, email address, postal address and contents.

NVD CVE-2026-103376WPScan advisory

medium 4.3 CVE-2026-9618 · published 2026-05-28

Cross-site request forgery (CSRF) in PeachPay (1.120.46 and older)

Affected
1.120.46 and older
Fixed in
1.120.47 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeachPay — Payments & Express Checkout for WooCommerce (supports Stripe, PayPal, Square, Authorize.net, NMI) plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.120.46. This is due to missing or incorrect nonce validation on the peachpay_stripe_handle_admin_actions function. This makes it possible for unauthenticated attackers to permanently delete all stored Stripe credentials — including publishable keys, secret keys, webhook secrets, and Apple Pay configuration — from the WordPress database, disabling Stripe payment processing for the store via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-9618Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-14978 · published 2026-01-20

Missing authorization check in PeachPay (1.119.8 and older)

Affected
1.119.8 and older
Fixed in
1.119.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PeachPay — Payments & Express Checkout for WooCommerce (supports Stripe, PayPal, Square, Authorize.net) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability checks on the ConvesioPay webhook REST endpoint in all versions up to, and including, 1.119.8. This makes it possible for unauthenticated attackers to modify the status of arbitrary WooCommerce orders.

NVD CVE-2025-14978Wordfence advisoryPlugin source

medium 6.5 CVE-2025-9463 · published 2025-09-10

SQL injection in PeachPay (1.117.5 and older)

Affected
1.117.5 and older
Fixed in
1.117.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Payments Plugin and Checkout Plugin for WooCommerce: Stripe, PayPal, Square, Authorize.net plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 1.117.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-9463Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.3 CVE-2025-58634 · published 2025-09-03

Missing authorization check in PeachPay (1.117.4 and older)

Affected
1.117.4 and older
Fixed in
1.117.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in peachpay PeachPay Payments peachpay-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PeachPay Payments: from n/a through <= 1.117.4.

NVD CVE-2025-58634Patchstack advisory

medium 6.1 CVE-2024-11362 · published 2024-11-23

Reflected cross-site scripting (XSS) in PeachPay (1.112.0 and older)

Affected
1.112.0 and older
Fixed in
1.114.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Payments Plugin and Checkout Plugin for WooCommerce: Stripe, PayPal, Square, Authorize.net plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.112.0. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-11362Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PeachPay vulnerability status badge
<a href="https://laskyr.com/plugins/peachpay-for-woocommerce"><img src="https://laskyr.com/plugins/peachpay-for-woocommerce/badge.svg" alt="PeachPay vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit