Skip to content
Laskyr

Plugins · pdf-poster · data as of 2026-11-04

Is PDF Poster safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.3)

As of 2026-11-04. 4 issues are on record for older versions; version 2.6.2 or newer fixes all of them that state a fix.

Latest version
2.6.3
Last updated
2026-11-01
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Embed PDF files in WordPress with a responsive PDF viewer, flipbook, shortcode and Gutenberg block, plus print, download and view analytics. — by bPlugins

What to do

  1. Update to the latest version (2.6.3). Anything older than 2.6.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pdf-poster --field=version shows what you run; wp plugin update pdf-poster updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-48195 · published 2026-10-29

Stored cross-site scripting (XSS) in PDF Poster (2.6.1 and older)

Affected
2.6.1 and older
Fixed in
2.6.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins PDF Poster pdf-poster allows Stored XSS.This issue affects PDF Poster: from n/a through 2.6.1.

NVD CVE-2026-48195Patchstack advisory

medium 5.3 CVE-2026-27416 · published 2026-05-07

Missing authorization check in PDF Poster (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.5.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bPlugins PDF Poster allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects PDF Poster: from n/a through 2.4.1.

NVD CVE-2026-27416Patchstack advisory

medium 5.4 CVE-2026-32416 · published 2026-03-13

Missing authorization check in PDF Poster (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bPlugins PDF Poster pdf-poster allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PDF Poster: from n/a through <= 2.4.0.

NVD CVE-2026-32416Patchstack advisory

medium 6.1 CVE-2024-23508 · published 2024-01-31

Reflected cross-site scripting (XSS) in PDF Poster (2.1.17 and older)

Affected
2.1.17 and older
Fixed in
2.1.18
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins PDF Poster – PDF Embedder Plugin for WordPress allows Reflected XSS.This issue affects PDF Poster – PDF Embedder Plugin for WordPress: from n/a through 2.1.17.

NVD CVE-2024-23508Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PDF Poster vulnerability status badge
<a href="https://laskyr.com/plugins/pdf-poster"><img src="https://laskyr.com/plugins/pdf-poster/badge.svg" alt="PDF Poster vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit