Plugins · pdf-generator-for-wp · data as of 2026-11-04
Is PDF Generator for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 1.6.5
- Last updated
- 2026-10-15
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
PDF Generator for WordPress allows you to convert posts into PDF files to share information across multiple channels. — by WP Swings
What to do
- Update to the latest version (1.6.5). Anything older than 1.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pdf-generator-for-wp --field=version shows what you run; wp plugin update pdf-generator-for-wp updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-57407 · published 2026-07-13
Server-side request forgery (SSRF) in PDF Generator for WordPress (1.6.2 and older)
- Affected
- 1.6.2 and older
- Fixed in
- 1.6.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in WP Swings PDF Generator for WordPress pdf-generator-for-wp allows Server Side Request Forgery.This issue affects PDF Generator for WordPress: from n/a through <= 1.6.2.
medium 5.3 CVE-2025-58978 · published 2025-09-09
Missing authorization check in PDF Generator for WordPress (1.5.4 and older)
- Affected
- 1.5.4 and older
- Fixed in
- 1.5.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP Swings PDF Generator for WordPress pdf-generator-for-wp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PDF Generator for WordPress: from n/a through <= 1.5.4.
medium 6.1 CVE-2022-4321 · published 2023-02-06
Reflected cross-site scripting (XSS) in PDF Generator for WordPress (older than 1.1.2)
- Affected
- older than 1.1.2
- Fixed in
- 1.1.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The PDF Generator for WordPress plugin before 1.1.2 includes a vendored dompdf example file which is susceptible to Reflected Cross-Site Scripting and could be used against high privilege users such as admin
Recent activity
- 2026-10-15 — latest release on wordpress.org (1.6.5).
- 2026-07-13 — Server-side request forgery (SSRF) disclosed (CVE-2026-57407), fixed in 1.6.3.
- 2025-09-09 — Missing authorization check disclosed (CVE-2025-58978), fixed in 1.5.5.
- 2023-02-06 — Reflected cross-site scripting (XSS) disclosed (CVE-2022-4321), fixed in 1.1.2.
Get an email when PDF Generator for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PDF Generator for WordPress (pdf-generator-for-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WP Swings (9 tracked)
Types found in this plugin: Server-side request forgery (SSRF) (1) · Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pdf-generator-for-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pdf-generator-for-wp"><img src="https://laskyr.com/plugins/pdf-generator-for-wp/badge.svg" alt="PDF Generator for WordPress vulnerability status"></a>