Plugins · pdf-for-wpforms · data as of 2026-11-04
Is PDF for WPForms + Drag and Drop Template Builder safe? Known vulnerabilities and latest version
- Latest version
- 7.2.0
- Last updated
- 2026-09-20
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
PDF Builder for WPForms helps you create custom PDF documents from form submissions using a powerful drag-and-drop template builder. — by add-ons.org
What to do
- Update to the latest version (7.2.0). Anything older than 6.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pdf-for-wpforms --field=version shows what you run; wp plugin update pdf-for-wpforms updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-68534 · published 2026-02-20
Missing authorization check in PDF for WPForms + Drag and Drop Template Builder (6.3.0 and older)
- Affected
- 6.3.0 and older
- Fixed in
- 6.3.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in add-ons.org PDF for WPForms pdf-for-wpforms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PDF for WPForms: from n/a through <= 6.3.0.
high 8.8 CVE-2025-60082 · published 2025-12-18
PHP object injection in PDF for WPForms + Drag and Drop Template Builder (6.5.0 and older)
- Affected
- 6.5.0 and older
- Fixed in
- 6.5.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in add-ons.org PDF for WPForms pdf-for-wpforms allows Object Injection.This issue affects PDF for WPForms: from n/a through <= 6.5.0.
medium 6.5 CVE-2025-58620 · published 2025-09-03
Stored cross-site scripting (XSS) in PDF for WPForms + Drag and Drop Template Builder (6.2.1 and older)
- Affected
- 6.2.1 and older
- Fixed in
- 6.3.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in add-ons.org PDF for WPForms pdf-for-wpforms allows Stored XSS.This issue affects PDF for WPForms: from n/a through <= 6.2.1.
medium 5.0 CVE-2025-49289 · published 2025-06-06
Missing authorization check in PDF for WPForms + Drag and Drop Template Builder (5.5.0 and older)
- Affected
- 5.5.0 and older
- Fixed in
- 5.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in add-ons.org PDF for WPForms pdf-for-wpforms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PDF for WPForms: from n/a through <= 5.5.0.
medium 5.4 CVE-2025-30767 · published 2025-03-27
Missing authorization check in PDF for WPForms + Drag and Drop Template Builder (5.3.0 and older)
- Affected
- 5.3.0 and older
- Fixed in
- 5.3.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in add-ons.org PDF for WPForms pdf-for-wpforms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PDF for WPForms: from n/a through <= 5.3.0.
medium 6.4 CVE-2024-12593 · published 2025-01-15
Stored cross-site scripting (XSS) in PDF for WPForms + Drag and Drop Template Builder (4.6.0 and older)
- Affected
- 4.6.0 and older
- Fixed in
- 6.2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PDF for WPForms + Drag and Drop Template Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's yeepdf_dotab shortcode in all versions up to, and including, 4.6.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-12593Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-09-20 — latest release on wordpress.org (7.2.0).
- 2026-02-20 — Missing authorization check disclosed (CVE-2025-68534), fixed in 6.3.1.
- 2025-12-18 — PHP object injection disclosed (CVE-2025-60082), fixed in 6.5.1.
- 2025-09-03 — Stored cross-site scripting (XSS) disclosed (CVE-2025-58620), fixed in 6.3.0.
Get an email when PDF for WPForms + Drag and Drop Template Builder has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PDF for WPForms + Drag and Drop Template Builder (pdf-for-wpforms) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by add-ons.org (10 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pdf-for-wpforms (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pdf-for-wpforms"><img src="https://laskyr.com/plugins/pdf-for-wpforms/badge.svg" alt="PDF for WPForms + Drag and Drop Template Builder vulnerability status"></a>