Skip to content
Laskyr

Plugins · pdf-for-woocommerce · data as of 2026-11-04

Is PDF Invoice for WooCommerce + Drag and Drop Te… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.2.0)

As of 2026-11-04. 4 issues are on record for older versions; version 7.2.0 or newer fixes all of them that state a fix.

Latest version
7.2.0
Last updated
2026-10-29
Active installs
500+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Provides features to create PDF files from form submissions and attach files to email notifications. — by add-ons.org

What to do

  1. Update to the latest version (7.2.0). Anything older than 7.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pdf-for-woocommerce --field=version shows what you run; wp plugin update pdf-for-woocommerce updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-109220 · published 2026-10-31

PHP object injection in PDF Invoice for WooCommerce + Drag and Drop Te… (7.1.1 and older)

Affected
7.1.1 and older
Fixed in
7.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PDF Invoice for WooCommerce + Drag and Drop Template Builder plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 7.1.1 via the 'customer_note' parameter parameter. This is due to insufficient sanitization of the customer_note checkout field, which is inlined verbatim into invoice HTML, entity-decoded back into a live tag by simplehtmldom, reassembled into raw bytes by mPDF, and passed to unserialize() in _getObjAttr without validation. This makes it possible for unauthenticated attackers to execute code on the server. An unauthenticated attacker can trigger the vulnerable code path on a default install by placing an anonymous WooCommerce checkout via the public Store API (POST /wc/store/v1/checkout) using a Direct Bank Transfer or cheque payment method, which automatically transitions the order to 'on-hold' status and fires the plugin's invoice-generation hook.

NVD CVE-2026-109220Wordfence advisorydownloads.wordpress.orgPlugin source

high 8.8 CVE-2025-60083 · published 2025-12-18

PHP object injection in PDF Invoice for WooCommerce + Drag and Drop Te… (6.5.0 and older)

Affected
6.5.0 and older
Fixed in
6.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in add-ons.org PDF Invoice Builder for WooCommerce pdf-for-woocommerce allows Object Injection.This issue affects PDF Invoice Builder for WooCommerce: from n/a through <= 6.5.0.

NVD CVE-2025-60083Patchstack advisory

high 7.6 CVE-2025-47537 · published 2025-05-07

SQL injection in PDF Invoice for WooCommerce + Drag and Drop Te… (5.3.8 and older)

Affected
5.3.8 and older
Fixed in
5.4.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in add-ons.org PDF Invoice Builder for WooCommerce pdf-for-woocommerce allows SQL Injection.This issue affects PDF Invoice Builder for WooCommerce: from n/a through <= 5.3.8.

NVD CVE-2025-47537Patchstack advisory

medium 6.5 CVE-2025-24755 · published 2025-01-24

Stored cross-site scripting (XSS) in PDF Invoice for WooCommerce + Drag and Drop Te… (4.6.0 and older)

Affected
4.6.0 and older
Fixed in
4.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in add-ons.org PDF Invoice Builder for WooCommerce pdf-for-woocommerce allows Stored XSS.This issue affects PDF Invoice Builder for WooCommerce: from n/a through <= 4.6.0.

NVD CVE-2025-24755Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PDF Invoice for WooCommerce + Drag and Drop Te… vulnerability status badge
<a href="https://laskyr.com/plugins/pdf-for-woocommerce"><img src="https://laskyr.com/plugins/pdf-for-woocommerce/badge.svg" alt="PDF Invoice for WooCommerce + Drag and Drop Te… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit