Plugins · pdf-embedder · data as of 2026-11-01
Is PDF Embedder safe? Known vulnerabilities and latest version
- Latest version
- 5.0.2
- Last updated
- 2026-08-14
- Active installs
- 300,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Embed PDF files in WordPress posts and pages with a responsive PDF viewer block, live Block Editor preview, and no third-party services. — by Syed Balkhi
What to do
- Update to the latest version (5.0.2). Anything older than 5.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pdf-embedder --field=version shows what you run; wp plugin update pdf-embedder updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-7526 · published 2026-05-28
Information disclosure in PDF Embedder (4.9.3 and older)
- Affected
- 4.9.3 and older
- Fixed in
- 5.0.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PDF Embedder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.9.3 via the enqueue_block_assets. This makes it possible for authenticated attackers, with contributor-level access and above, to extract configuration data. License key exposure occurs when the premium add-on is also installed and has saved a key; on Lite-only installations, the exposed data is limited to non-sensitive viewer configuration values such as width, height, toolbar settings, usage tracking, and plan.
NVD CVE-2026-7526Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source
medium 5.5 CVE-2024-29141 · published 2024-03-19
Stored cross-site scripting (XSS) in PDF Embedder (4.6.4 and older)
- Affected
- 4.6.4 and older
- Fixed in
- 4.7.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PDF Embedder allows Stored XSS.This issue affects PDF Embedder: from n/a through 4.6.4.
critical 9.8 CVE-2019-19589 · published 2019-12-05
Security issue in PDF Embedder (4.4 only)
- Affected
- 4.4 only
- Fixed in
- 4.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Lever PDF Embedder plugin 4.4 for WordPress does not block the distribution of polyglot PDF documents that are valid JAR archives. Note: It has been argued that "The vulnerability reported in PDF Embedder Plugin is not valid as the plugin itself doesn't control or manage the file upload process. It only serves the uploaded PDF files and the responsibility of uploading PDF file remains with the Site owner of Wordpress installation, the upload of PDF file is managed by Wordpress core and not by PDF Embedder Plugin. Control & block of polyglot file is required to be taken care at the time of upload, not on showing the file. Moreover, the reference mentions retrieving the files from the browser cache and manually renaming it to jar for executing the file. That refers to a two step non-connected steps which has nothing to do with PDF Embedder.
Recent activity
- 2026-08-14 — latest release on wordpress.org (5.0.2).
- 2026-05-28 — Information disclosure disclosed (CVE-2026-7526), fixed in 5.0.0.
- 2024-03-19 — Stored cross-site scripting (XSS) disclosed (CVE-2024-29141), fixed in 4.7.1.
- 2019-12-05 — Security issue disclosed (CVE-2019-19589), fixed in 4.5.
Get an email when PDF Embedder has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PDF Embedder (pdf-embedder) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pdf-embedder (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pdf-embedder"><img src="https://laskyr.com/plugins/pdf-embedder/badge.svg" alt="PDF Embedder vulnerability status"></a>