Plugins · payplus-payment-gateway · data as of 2026-11-04
Is PayPlus Payment Gateway safe? Known vulnerabilities and latest version
- Latest version
- 8.3.1
- Last updated
- 2026-10-14
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Accept credit/debit card payments or other methods such as bit, Apple Pay, Google Pay in one page. Create digitally signed invoices & much more! — by PayPlus Tech Team
What to do
- Update to the latest version (8.3.1). Anything older than 8.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get payplus-payment-gateway --field=version shows what you run; wp plugin update payplus-payment-gateway updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-93620 · published 2026-09-23
Missing authorization check in PayPlus Payment Gateway (8.2.5 and older)
- Affected
- 8.2.5 and older
- Fixed in
- 8.2.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in PayPlus Payment Gateway <= 8.2.5 versions.
medium 5.3 CVE-2026-12972 · published 2026-07-20
Missing authorization check in PayPlus Payment Gateway (older than 8.2.2)
- Affected
- older than 8.2.2
- Fixed in
- 8.2.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The PayPlus Payment Gateway WordPress plugin before 8.2.2 does not perform authorization or order-ownership validation in one of its AJAX actions available to unauthenticated users, allowing them to tamper with the payment-related metadata of arbitrary WooCommerce orders.
medium 6.5 CVE-2026-12973 · published 2026-07-20
Missing authorization check in PayPlus Payment Gateway (older than 8.2.2)
- Affected
- older than 8.2.2
- Fixed in
- 8.2.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The PayPlus Payment Gateway WordPress plugin before 8.2.2 does not perform authorization or order-ownership validation in one of its AJAX actions available to unauthenticated users, allowing them to disclose the secret order key of arbitrary WooCommerce orders and, under some configurations, to modify order statuses.
medium 6.1 CVE-2024-37459 · published 2024-07-21
Reflected cross-site scripting (XSS) in PayPlus Payment Gateway (6.6.8 and older)
- Affected
- 6.6.8 and older
- Fixed in
- 6.6.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in PayPlus LTD PayPlus Payment Gateway allows Reflected XSS.This issue affects PayPlus Payment Gateway: from n/a through 6.6.8.
critical 9.8 CVE-2024-6205 · published 2024-07-19
SQL injection in PayPlus Payment Gateway (older than 6.6.9)
- Affected
- older than 6.6.9
- Fixed in
- 6.6.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The PayPlus Payment Gateway WordPress plugin before 6.6.9 does not properly sanitise and escape a parameter before using it in a SQL statement via a WooCommerce API route available to unauthenticated users, leading to an SQL injection vulnerability.
high 8.5 CVE-2024-37564 · published 2024-07-12
SQL injection in PayPlus Payment Gateway (7.0.7 and older)
- Affected
- 7.0.7 and older
- Fixed in
- 7.0.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in PayPlus LTD PayPlus Payment Gateway.This issue affects PayPlus Payment Gateway: from n/a through 7.0.7.
Recent activity
- 2026-10-14 — latest release on wordpress.org (8.3.1).
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-93620), fixed in 8.2.6.
- 2026-07-20 — Missing authorization check disclosed (CVE-2026-12972), fixed in 8.2.2.
- 2026-07-20 — Missing authorization check disclosed (CVE-2026-12973), fixed in 8.2.2.
Get an email when PayPlus Payment Gateway has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PayPlus Payment Gateway (payplus-payment-gateway) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · SQL injection (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/payplus-payment-gateway (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/payplus-payment-gateway"><img src="https://laskyr.com/plugins/payplus-payment-gateway/badge.svg" alt="PayPlus Payment Gateway vulnerability status"></a>