Plugins · payplug · data as of 2026-11-04
Is PayPlug for WooCommerce (Official) safe? Known vulnerabilities and latest version
- Latest version
- 3.1.1
- Last updated
- 2026-10-20
- Active installs
- 4,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.4+
PlayPlug is a French payment solution allowing small and medium e-commerce companies to accept online payments from Visa, MasterCard and CB cards. — by Payplug
What to do
- Update to the latest version (3.1.1). Anything older than 3.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get payplug --field=version shows what you run; wp plugin update payplug updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-113813 · published 2026-10-28
Missing authorization check in PayPlug for WooCommerce (Official) (2.8.0 up to (not including) 3.1.1)
- Affected
- 2.8.0 up to (not including) 3.1.1
- Fixed in
- 3.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The PayPlug for WooCommerce (Official) WordPress plugin before 3.1.1 does not perform any capability or ownership check on a set of unauthenticated AJAX actions that operate on a caller-supplied order identifier, allowing unauthenticated attackers to modify, read the contents of, and permanently delete arbitrary WooCommerce orders.
medium 6.5 CVE-2026-110292 · published 2026-10-28
Information disclosure in PayPlug for WooCommerce (Official) (2.9.0 up to (not including) 3.1.1)
- Affected
- 2.9.0 up to (not including) 3.1.1
- Fixed in
- 3.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The PayPlug for WooCommerce (Official) WordPress plugin before 3.1.1 does not verify that the requester owns the WooCommerce order named in a payment request, allowing unauthenticated users to disclose another customer's order key and cancel their unpaid guest order.
medium 6.5 CVE-2026-42637 · published 2026-10-06
Missing authorization check in PayPlug for WooCommerce (Official) (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Settings Change in PayPlug for WooCommerce (Official) <= 3.1.0 versions.
high 7.5 CVE-2026-39751 · published 2026-10-06
Missing authorization check in PayPlug for WooCommerce (Official) (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in PayPlug for WooCommerce (Official) <= 3.1.0 versions.
Recent activity
- 2026-10-20 — latest release on wordpress.org (3.1.1).
- 2026-10-28 — Missing authorization check disclosed (CVE-2026-113813), fixed in 3.1.1.
- 2026-10-28 — Information disclosure disclosed (CVE-2026-110292), fixed in 3.1.1.
- 2026-10-06 — Missing authorization check disclosed (CVE-2026-42637), fixed in 3.1.1.
Get an email when PayPlug for WooCommerce (Official) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PayPlug for WooCommerce (Official) (payplug) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/payplug (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/payplug"><img src="https://laskyr.com/plugins/payplug/badge.svg" alt="PayPlug for WooCommerce (Official) vulnerability status"></a>