Plugins · paypal-brasil-para-woocommerce · data as of 2026-11-04
Is PayPal Brasil para WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 1.8.2
- Last updated
- 2026-10-28
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.0 · PHP 7.4+
Easily add PayPal payment options to your WooCommerce store. — by Otávio Augusto
What to do
- Update to the latest version (1.8.2). Anything older than 1.7.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get paypal-brasil-para-woocommerce --field=version shows what you run; wp plugin update paypal-brasil-para-woocommerce updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-76058 · published 2026-10-28
Missing authorization check in PayPal Brasil para WooCommerce (1.7.8 and older)
- Affected
- 1.7.8 and older
- Fixed in
- 1.7.9 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PayPal Brasil para WooCommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.7.8. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to disable or enable the PayPal Brasil BCDC payment gateway and overwrite its WooCommerce gateway settings, removing PayPal from checkout for all customers.
NVD CVE-2026-76058Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2023-25026 · published 2024-12-09
Missing authorization check in PayPal Brasil para WooCommerce (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.4.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in PayPal PayPal Brasil para WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PayPal Brasil para WooCommerce: from n/a through 1.4.2.
Recent activity
- 2026-10-28 — latest release on wordpress.org (1.8.2).
- 2026-10-28 — Missing authorization check disclosed (CVE-2026-76058), fixed in 1.7.9.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-25026), fixed in 1.4.3.
Get an email when PayPal Brasil para WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PayPal Brasil para WooCommerce (paypal-brasil-para-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/paypal-brasil-para-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/paypal-brasil-para-woocommerce"><img src="https://laskyr.com/plugins/paypal-brasil-para-woocommerce/badge.svg" alt="PayPal Brasil para WooCommerce vulnerability status"></a>