Plugins · paymob-for-woocommerce · data as of 2026-11-04
Is Paymob for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.1.16
- Last updated
- 2026-11-02
- Active installs
- 5,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Paymob Payment for WooCommerce. — by Paymob
What to do
- Update to the latest version (4.1.16). Anything older than 4.1.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get paymob-for-woocommerce --field=version shows what you run; wp plugin update paymob-for-woocommerce updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-87978 · published 2026-09-23
Security issue in Paymob for WooCommerce (older than 4.1.14)
- Affected
- older than 4.1.14
- Fixed in
- 4.1.14
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Paymob for WooCommerce WordPress plugin before 4.1.14 does not verify the request signature on one branch of its payment webhook, allowing unauthenticated attackers to mark arbitrary WooCommerce orders as paid without any payment.
medium 5.3 CVE-2026-87979 · published 2026-09-23
Missing authorization check in Paymob for WooCommerce (older than 4.1.14)
- Affected
- older than 4.1.14
- Fixed in
- 4.1.14
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Paymob for WooCommerce WordPress plugin before 4.1.14 does not verify the request signature on the card-token branch of its payment webhook, allowing unauthenticated attackers to write a card-token record to any user's account and to enumerate registered accounts.
medium 4.7 CVE-2026-87981 · published 2026-09-23
Missing authorization check in Paymob for WooCommerce (older than 4.1.14)
- Affected
- older than 4.1.14
- Fixed in
- 4.1.14
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Paymob for WooCommerce WordPress plugin before 4.1.14 does not perform a capability check on several admin AJAX actions that manage its payment-gateway configuration, allowing users with contributor-level access to delete, wipe, or modify that configuration, including the stored payment credentials.
high 7.1 CVE-2026-66611 · published 2026-08-20
Cross-site scripting (XSS) in Paymob for WooCommerce (4.1.10 and older)
- Affected
- 4.1.10 and older
- Fixed in
- 4.1.11
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Paymob for WooCommerce <= 4.1.10 versions.
high 8.6 CVE-2026-15205 · published 2026-08-14
SQL injection in Paymob for WooCommerce (older than 4.1.9)
- Affected
- older than 4.1.9
- Fixed in
- 4.1.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Paymob for WooCommerce WordPress plugin before 4.1.9 does not properly sanitise a client-supplied identifier before using it in a SQL query within its public, unauthenticated payment callback, and performs this query before verifying the payment provider's HMAC signature. This allows unauthenticated attackers to perform SQL injection and read arbitrary data from the database — including user credentials and other secrets — through both in-band (reflected) and time-based blind extraction.
high 7.5 CVE-2026-56025 · published 2026-06-26
Missing authorization check in Paymob for WooCommerce (4.1.2 and older)
- Affected
- 4.1.2 and older
- Fixed in
- 4.1.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Paymob for WooCommerce <= 4.1.2 versions.
Recent activity
- 2026-11-02 — latest release on wordpress.org (4.1.16).
- 2026-09-23 — Security issue disclosed (CVE-2026-87978), fixed in 4.1.14.
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-87979), fixed in 4.1.14.
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-87981), fixed in 4.1.14.
Get an email when Paymob for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Paymob for WooCommerce (paymob-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/paymob-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/paymob-for-woocommerce"><img src="https://laskyr.com/plugins/paymob-for-woocommerce/badge.svg" alt="Paymob for WooCommerce vulnerability status"></a>