Skip to content
Laskyr

Plugins · payment-page · data as of 2026-11-04

Is Payment Page safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.4.7 or newer fixes all of them that state a fix.

Latest version
1.6.1
Last updated
2026-10-08
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Accept Stripe payments on WordPress without WooCommerce. One-time and recurring forms, 26 form templates, Elementor, and PayPal one-time checkout. — by Brandon Ernst

What to do

  1. Update to the latest version (1.6.1). Anything older than 1.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get payment-page --field=version shows what you run; wp plugin update payment-page updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-0751 · published 2026-02-14

Stored cross-site scripting (XSS) in Payment Page (1.4.6 and older)

Affected
1.4.6 and older
Fixed in
1.4.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Payment Page | Payment Form for Stripe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pricing_plan_select_text_font_family' parameter in all versions up to, and including, 1.4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0751Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Payment Page vulnerability status badge
<a href="https://laskyr.com/plugins/payment-page"><img src="https://laskyr.com/plugins/payment-page/badge.svg" alt="Payment Page vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit