Plugins · payment-gateway-stripe-and-woocommerce-integration · data as of 2026-11-04
Is Payment Gateway of Stripe for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 5.1.1
- Last updated
- 2026-10-09
- Active installs
- 7,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Integrate Stripe Payment Gateway in WooCommerce and accept cards, Google Pay, Apple Pay, Klarna, Alipay, and more with seamless, secure checkout. — by ThemeHigh
What to do
- Update to the latest version (5.1.1). Anything older than 5.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get payment-gateway-stripe-and-woocommerce-integration --field=version shows what you run; wp plugin update payment-gateway-stripe-and-woocommerce-integration updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-9832 · published 2026-09-19
Security issue in Payment Gateway of Stripe for WooCommerce (5.0.8 and older)
- Affected
- 5.0.8 and older
- Fixed in
- 5.0.9 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Gateway of Stripe for WooCommerce plugin for WordPress is vulnerable to Improper Verification of Cryptographic Signature in all versions up to, and including, 5.0.8. This is due to the publicly accessible `woocommerce_api_wt_stripe` webhook endpoint (`EH_Stripe_Webhook_Handler::handle()`) wrapping the only call to `\Stripe\Webhook::constructEvent()` inside an `if (!empty($endpoint_secret))` guard that is never entered on default installations — because the `eh_stripe_webhook_secret` option is empty after a fresh plugin install — causing the raw, attacker-controlled POST body to be decoded and processed as a fully trusted Stripe event without any signature verification, authentication, or authorization. This makes it possible for unauthenticated attackers to send forged Stripe webhook events to manipulate WooCommerce order statuses, including marking unpaid orders as paid or completed via `payment_complete()`, forcing legitimate orders into a failed state, fabricating dispute notifications, and injecting forged refund events. This vulnerability is only exploitable when the Stripe webhook signing secret has not been configured by an administrator; once a valid signing secret is saved, `\Stripe\Webhook::constructEvent()` is enforced and forged requests are rejected.
NVD CVE-2026-9832Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-45217 · published 2026-05-25
Authentication bypass in Payment Gateway of Stripe for WooCommerce (5.0.7 and older)
- Affected
- 5.0.7 and older
- Fixed in
- 5.0.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authentication Bypass Using an Alternate Path or Channel vulnerability in ThemeHigh Stripe Payment Gateway for WooCommerce allows Password Recovery Exploitation. This issue affects Stripe Payment Gateway for WooCommerce: from n/a through 5.0.7.
high 7.5 CVE-2024-0705 · published 2024-01-19
SQL injection in Payment Gateway of Stripe for WooCommerce (3.7.9 and older)
- Affected
- 3.7.9 and older
- Fixed in
- 3.8.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in all versions up to, and including, 3.7.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
critical 9.8 CVE-2023-3162 · published 2023-08-31
Authentication bypass in Payment Gateway of Stripe for WooCommerce (3.7.7 and older)
- Affected
- 3.7.7 and older
- Fixed in
- 3.7.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Stripe Payment Plugin for WooCommerce plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.7.7. This is due to insufficient verification on the user being supplied during a Stripe checkout through the plugin. This allows unauthenticated attackers to log in as users who have orders, who are typically customers.
NVD CVE-2023-3162Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-09 — latest release on wordpress.org (5.1.1).
- 2026-09-19 — Security issue disclosed (CVE-2026-9832), fixed in 5.0.9.
- 2026-05-25 — Authentication bypass disclosed (CVE-2026-45217), fixed in 5.0.8.
- 2024-01-19 — SQL injection disclosed (CVE-2024-0705), fixed in 3.8.0.
Get an email when Payment Gateway of Stripe for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Payment Gateway of Stripe for WooCommerce (payment-gateway-stripe-and-woocommerce-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ThemeHigh (5 tracked)
Types found in this plugin: Authentication bypass (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/payment-gateway-stripe-and-woocommerce-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/payment-gateway-stripe-and-woocommerce-integration"><img src="https://laskyr.com/plugins/payment-gateway-stripe-and-woocommerce-integration/badge.svg" alt="Payment Gateway of Stripe for WooCommerce vulnerability status"></a>