Plugins · payment-forms-for-paystack · data as of 2026-11-04
Is Payment Forms for Paystack safe? Known vulnerabilities and latest version
- Latest version
- 4.0.7
- Last updated
- 2026-10-28
- Active installs
- 2,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.4+
Create forms with multiple input fields and have your users pay before submission. Form submission results are available on your dashboard. — by kendysond
What to do
- Update to the latest version (4.0.7). Anything older than 4.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get payment-forms-for-paystack --field=version shows what you run; wp plugin update payment-forms-for-paystack updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-110042 · published 2026-10-31
Information disclosure in Payment Forms for Paystack (older than 4.0.6)
- Affected
- older than 4.0.6
- Fixed in
- 4.0.6
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Payment Forms for Paystack WordPress plugin before 4.0.6 does not properly restrict access to a page that displays its stored configuration, allowing users with the Contributor role and above to view secret payment-gateway API credentials, both the live and test secret keys, which grant full access to the site owner's payment account.
medium 6.5 CVE-2026-66444 · published 2026-08-13
Information disclosure in Payment Forms for Paystack (4.0.5 and older)
- Affected
- 4.0.5 and older
- Fixed in
- 4.0.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Sensitive Data Exposure in Payment Forms for Paystack <= 4.0.5 versions.
medium 6.4 CVE-2024-10894 · published 2025-04-10
Stored cross-site scripting (XSS) in Payment Forms for Paystack (4.0.2 and older)
- Affected
- 4.0.2 and older
- Fixed in
- 4.0.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Forms for Paystack plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes like 'datepicker', 'textarea', and 'text' in all versions up to, and including, 4.0.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-10894Wordfence advisoryCode change (fix)Plugin source
high 7.6 CVE-2025-22652 · published 2025-03-27
SQL injection in Payment Forms for Paystack (4.0.1 and older)
- Affected
- 4.0.1 and older
- Fixed in
- 4.0.2
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in kendysond Payment Forms for Paystack payment-forms-for-paystack allows SQL Injection.This issue affects Payment Forms for Paystack: from n/a through <= 4.0.1.
medium 6.5 CVE-2024-32130 · published 2024-04-17
Stored cross-site scripting (XSS) in Payment Forms for Paystack (3.4.1 and older)
- Affected
- 3.4.1 and older
- Fixed in
- 3.4.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Paystack Payment Forms for Paystack allows Stored XSS.This issue affects Payment Forms for Paystack: from n/a through 3.4.1.
medium 5.4 CVE-2023-5665 · published 2024-02-08
Stored cross-site scripting (XSS) in Payment Forms for Paystack (3.4.1 and older)
- Affected
- 3.4.1 and older
- Fixed in
- 3.4.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Payment Forms for Paystack plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in all versions up to, and including, 3.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-32130 is likely a duplicate of this issue.
NVD CVE-2023-5665Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-28 — latest release on wordpress.org (4.0.7).
- 2026-10-31 — Information disclosure disclosed (CVE-2026-110042), fixed in 4.0.6.
- 2026-08-13 — Information disclosure disclosed (CVE-2026-66444), fixed in 4.0.6.
- 2025-04-10 — Stored cross-site scripting (XSS) disclosed (CVE-2024-10894), fixed in 4.0.3.
Get an email when Payment Forms for Paystack has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Payment Forms for Paystack (payment-forms-for-paystack) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/payment-forms-for-paystack (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/payment-forms-for-paystack"><img src="https://laskyr.com/plugins/payment-forms-for-paystack/badge.svg" alt="Payment Forms for Paystack vulnerability status"></a>