Plugins · payhere-payment-gateway · data as of 2026-11-04
Is PayHere Payment Gateway safe? Known vulnerabilities and latest version
- Latest version
- 2.4.6
- Last updated
- 2026-10-30
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
PayHere Payment Gateway — by PayHere
What to do
- Update to the latest version (2.4.6). Anything older than 2.4.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get payhere-payment-gateway --field=version shows what you run; wp plugin update payhere-payment-gateway updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-103310 · published 2026-11-02
Security issue in PayHere Payment Gateway (2.4.0 to 2.4.5)
- Affected
- 2.4.0 to 2.4.5
- Fixed in
- 2.4.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The PayHere Payment Gateway WordPress plugin from 2.4.0 through 2.4.5 does not verify the authenticity of payment notifications when the merchant secret is unset, which is the default state, allowing unauthenticated attackers to forge a payment confirmation and mark any order as paid without payment.
medium 5.3 CVE-2025-15475 · published 2026-01-14
Missing authorization check in PayHere Payment Gateway (2.3.9 and older)
- Affected
- 2.3.9 and older
- Fixed in
- 2.4.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PayHere Payment Gateway Plugin for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to an improper validation logic in the check_payhere_response function in all versions up to, and including, 2.3.9. This makes it possible for unauthenticated attackers to change the status of pending WooCommerce orders to paid/completed/on hold.
NVD CVE-2025-15475Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2023-6064 · published 2024-01-01
Information disclosure in PayHere Payment Gateway (older than 2.2.12)
- Affected
- older than 2.2.12
- Fixed in
- 2.2.12
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The PayHere Payment Gateway WordPress plugin before 2.2.12 automatically creates publicly-accessible log files containing sensitive information when transactions occur.
Recent activity
- 2026-10-30 — latest release on wordpress.org (2.4.6).
- 2026-11-02 — Security issue disclosed (CVE-2026-103310), fixed in 2.4.6.
- 2026-01-14 — Missing authorization check disclosed (CVE-2025-15475), fixed in 2.4.0.
- 2024-01-01 — Information disclosure disclosed (CVE-2023-6064), fixed in 2.2.12.
Get an email when PayHere Payment Gateway has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PayHere Payment Gateway (payhere-payment-gateway) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/payhere-payment-gateway (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/payhere-payment-gateway"><img src="https://laskyr.com/plugins/payhere-payment-gateway/badge.svg" alt="PayHere Payment Gateway vulnerability status"></a>