Skip to content
Laskyr

Plugins · payflex-payment-gateway · data as of 2026-11-04

Is Payflex Payment Gateway safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.0)

As of 2026-11-04. 3 issues are on record for older versions; version 2.8.0 or newer fixes all of them that state a fix.

Latest version
2.8.0
Last updated
2026-09-30
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The Payflex extension for WooCommerce enables you to accept payments in installments via one of South Africa’s most popular payment gateways. — by tomlister

What to do

  1. Update to the latest version (2.8.0). Anything older than 2.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get payflex-payment-gateway --field=version shows what you run; wp plugin update payflex-payment-gateway updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-103346 · published 2026-10-06

Reflected cross-site scripting (XSS) in Payflex Payment Gateway (2.7.1 and older)

Affected
2.7.1 and older
Fixed in
2.8.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Tomlister Payflex Payment Gateway payflex-payment-gateway allows Reflected XSS.This issue affects Payflex Payment Gateway: from n/a through 2.7.1.

NVD CVE-2026-103346Patchstack advisory

medium 4.7 CVE-2024-47646 · published 2024-10-05

Open redirect in Payflex Payment Gateway (2.6.1 and older)

Affected
2.6.1 and older
Fixed in
2.6.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in tomlister Payflex Payment Gateway payflex-payment-gateway.This issue affects Payflex Payment Gateway: from n/a through <= 2.6.1.

NVD CVE-2024-47646Patchstack advisory

medium 5.3 CVE-2024-0619 · published 2024-07-11

Missing authorization check in Payflex Payment Gateway (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Payflex Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the payment_callback() function in all versions up to, and including, 2.5.0. This makes it possible for unauthenticated attackers to update the status of orders, which can potentially lead to revenue loss.

NVD CVE-2024-0619Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Payflex Payment Gateway vulnerability status badge
<a href="https://laskyr.com/plugins/payflex-payment-gateway"><img src="https://laskyr.com/plugins/payflex-payment-gateway/badge.svg" alt="Payflex Payment Gateway vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit