Skip to content
Laskyr

Plugins · password-requirements · data as of 2026-11-04

Is Teydea Login Security safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.10.0)

As of 2026-11-04. 1 issue is on record for older versions; version 3.7.2 or newer fixes all of them that state a fix.

Latest version
3.10.0
Last updated
2026-10-30
Active installs
400+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Define and enforce password policies for your WordPress site with length, complexity, and expiration rules. — by Teydea Studio

What to do

  1. Update to the latest version (3.10.0). Anything older than 3.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get password-requirements --field=version shows what you run; wp plugin update password-requirements updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-15992 · published 2026-07-28

Privilege escalation in Teydea Login Security (3.7.1 and older)

Affected
3.7.1 and older
Fixed in
3.7.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Password Policy plugin for WordPress is vulnerable to Privilege Escalation in all versions up to and including 3.7.1. This is due to missing authorization checks and nonce verification in the `get_user()` function of the `Module_Password_Hint` class, which unconditionally calls `WP_User::set_role()` with the attacker-supplied `role` parameter on any account resolved via `$_POST['user_login']`, without confirming the requesting user holds the capability to assign roles. This makes it possible for authenticated attackers, with subscriber-level access and above, to escalate their own privileges to Administrator by submitting a crafted POST request — with `action` set to `createuser` and `role` set to `administrator` — to the password-reset form endpoint. The vulnerable code path is reachable via the `password_hint` filter hooked during the WordPress password-reset form render, meaning an attacker need only possess a valid password-reset cookie to reach the sink.

NVD CVE-2026-15992Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Teydea Login Security vulnerability status badge
<a href="https://laskyr.com/plugins/password-requirements"><img src="https://laskyr.com/plugins/password-requirements/badge.svg" alt="Teydea Login Security vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit