Skip to content
Laskyr

Plugins · password-protected · data as of 2026-11-01

Is Password Protected safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.6)

As of 2026-11-01. 6 issues are on record for older versions; version 2.8.5 or newer fixes all of them that state a fix.

Latest version
2.8.6
Last updated
2026-10-30
Active installs
300,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Password protect your WordPress site with one password. Control access, whitelist trusted IPs, and monitor password activity. — by Saad Iqbal

What to do

  1. Update to the latest version (2.8.6). Anything older than 2.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get password-protected --field=version shows what you run; wp plugin update password-protected updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-93293 · published 2026-10-29

Stored cross-site scripting (XSS) in Password Protected (2.8.4 and older)

Affected
2.8.4 and older
Fixed in
2.8.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Password Protected plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the bundled Freemius SDK's purchase-completion handler in all versions up to, and including, 2.8.4 due to insufficient input sanitization and output escaping. Once the site's Freemius opt-in is complete (the normal state after an administrator clicks "Allow & Continue"), the handler processes the 'purchased_plan' request parameter on any wp-admin request from an authenticated user without any capability, nonce, or purchase validation, and stores it in a persistent, site-wide administrative notice. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts that execute automatically when an administrator views a standard admin page such as their Profile page.

NVD CVE-2026-93293Wordfence advisoryCode change (fix)ti.wordfence.io

low 3.7 CVE-2025-11244 · published 2025-10-25

Missing authorization check in Password Protected (2.7.11 and older)

Affected
2.7.11 and older
Fixed in
2.7.12 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Password Protected plugin for WordPress is vulnerable to authorization bypass via IP address spoofing in all versions up to, and including, 2.7.11. This is due to the plugin trusting client-controlled HTTP headers (such as X-Forwarded-For, HTTP_CLIENT_IP, and similar headers) to determine user IP addresses in the `pp_get_ip_address()` function when the "Use transients" feature is enabled. This makes it possible for attackers to bypass authorization by spoofing these headers with the IP address of a legitimately authenticated user, granted the "Use transients" option is enabled (non-default configuration) and the site is not behind a CDN or reverse proxy that overwrites these headers.

NVD CVE-2025-11244Wordfence advisoryresearch.cleantalk.orgPlugin source

medium 5.3 CVE-2025-3453 · published 2025-04-17

Information disclosure in Password Protected (2.7.7 and older)

Affected
2.7.7 and older
Fixed in
2.7.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Password Protected – Password Protect your WordPress Site, Pages, & WooCommerce Products – Restrict Content, Protect WooCommerce Category and more plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.7.7 via the 'password_protected_cookie' function. This makes it possible for unauthenticated attackers to extract sensitive data including all protected site content if the 'Use Transient' setting is enabled.

NVD CVE-2025-3453Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-0437 · published 2024-05-15

Information disclosure in Password Protected (2.6.6 and older)

Affected
2.6.6 and older
Fixed in
2.6.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Password Protected – Ultimate Plugin to Password Protect Your WordPress Content with Ease plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.6.6 via the API. This makes it possible for authenticated attackers, with subscriber access or higher, to extract post titles and content, thus bypassing the plugin's password protection.

NVD CVE-2024-0437Wordfence advisoryCode change (fix)

medium 4.8 CVE-2024-0656 · published 2024-02-29

Stored cross-site scripting (XSS) in Password Protected (2.6.6 and older)

Affected
2.6.6 and older
Fixed in
2.6.7 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Password Protected – Ultimate Plugin to Password Protect Your WordPress Content with Ease plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Google Captcha Site Key in all versions up to, and including, 2.6.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2024-0656Wordfence advisoryCode change (fix)

medium 4.8 CVE-2023-32580 · published 2023-06-23

Stored cross-site scripting (XSS) in Password Protected (2.6.2 and older)

Affected
2.6.2 and older
Fixed in
2.6.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in WPExperts Password Protected plugin <= 2.6.2 versions.

NVD CVE-2023-32580Patchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Password Protected vulnerability status badge
<a href="https://laskyr.com/plugins/password-protected"><img src="https://laskyr.com/plugins/password-protected/badge.svg" alt="Password Protected vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit