Skip to content
Laskyr

Plugins · passeum-ticketing · data as of 2026-11-04

Is Passeum Ticketing safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.1 or newer fixes all of them that state a fix.

Latest version
1.0.1
Last updated
2026-05-29
Active installs
fewer than 10
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Embedding the ticket purchase widget into your own WordPress website. — by Passeum Ticketing

What to do

  1. Update to the latest version (1.0.1). Anything older than 1.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get passeum-ticketing --field=version shows what you run; wp plugin update passeum-ticketing updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-7421 · published 2026-06-03

Stored cross-site scripting (XSS) in Passeum Ticketing (1.0 and older)

Affected
1.0 and older
Fixed in
1.0.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Passeum Ticketing plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 1.0. This is due to the `get_shop_url()` method returning the `shop_name` setting value without sanitization when it begins with "http", combined with insufficient validation in the `validate_shop_name()` function which only checks for empty values and string type. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary external scripts by setting the `shop_name` to an attacker-controlled URL (e.g., `https://attacker.com`), which causes the plugin to enqueue external JavaScript and CSS from the attacker-controlled domain via `wp_register_script()` and `wp_register_style()`. The injected scripts execute on every frontend page containing any Passeum Ticketing shortcode, affecting all site visitors. Please note that this does not affect single-site installations as administrators already have the `unfiltered_html` capability.

NVD CVE-2026-7421Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Passeum Ticketing vulnerability status badge
<a href="https://laskyr.com/plugins/passeum-ticketing"><img src="https://laskyr.com/plugins/passeum-ticketing/badge.svg" alt="Passeum Ticketing vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit