Skip to content
Laskyr

Plugins · parallax-section · data as of 2026-11-04

Is Parallax Section Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.0 or newer fixes all of them that state a fix.

Latest version
2.3.0
Last updated
2026-10-31
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Add Parallax scrolling effects in any section of your website. — by bPlugins

What to do

  1. Update to the latest version (2.3.0). Anything older than 2.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get parallax-section --field=version shows what you run; wp plugin update parallax-section updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-102378 · published 2026-10-01

Cross-site scripting (XSS) in Parallax Section Block (2.0.4 and older)

Affected
2.0.4 and older
Fixed in
2.1.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Parallax Section block <= 2.0.4 versions.

NVD CVE-2026-102378Patchstack advisory

high 7.1 CVE-2025-60079 · published 2025-12-18

Missing authorization check in Parallax Section Block (1.0.9 and older)

Affected
1.0.9 and older
Fixed in
2.0.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bPlugins Parallax Section block parallax-section allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Parallax Section block: from n/a through <= 1.0.9.

NVD CVE-2025-60079Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Parallax Section Block vulnerability status badge
<a href="https://laskyr.com/plugins/parallax-section"><img src="https://laskyr.com/plugins/parallax-section/badge.svg" alt="Parallax Section Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit