Plugins · paid-membership · data as of 2026-11-04
Is MicroPayments safe? Known vulnerabilities and latest version
- Latest version
- 3.2.14
- Last updated
- 2026-10-30
- Active installs
- 10+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.2+
Monetize digital content with creator subscriptions, micro-payments, and a tokens wallet system. — by videowhisper
What to do
- Update to the latest version (3.2.14). Anything older than 3.2.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get paid-membership --field=version shows what you run; wp plugin update paid-membership updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-107434 · published 2026-10-10
Security issue in MicroPayments (3.2.9 and older)
- Affected
- 3.2.9 and older
- Fixed in
- 3.2.10
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Bypass Vulnerability in MicroPayments <= 3.2.9 versions.
medium 4.3 CVE-2025-5937 · published 2025-06-28
Cross-site request forgery (CSRF) in MicroPayments (3.2.0 and older)
- Affected
- 3.2.0 and older
- Fixed in
- 3.2.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MicroPayments – Fans Paysite: Paid Creator Subscriptions, Digital Assets, Wallet plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.0. This is due to missing or incorrect nonce validation on the adminOptions() function. This makes it possible for unauthenticated attackers to reset the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-5937Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-31075 · published 2025-03-28
Stored cross-site scripting (XSS) in MicroPayments (2.9.29 and older)
- Affected
- 2.9.29 and older
- Fixed in
- 2.9.30
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in videowhisper MicroPayments paid-membership allows Stored XSS.This issue affects MicroPayments: from n/a through <= 2.9.29.
high 7.1 CVE-2025-26579 · published 2025-03-26
Reflected cross-site scripting (XSS) in MicroPayments (3.2.4 and older)
- Affected
- 3.2.4 and older
- Fixed in
- 3.2.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in videowhisper MicroPayments paid-membership allows Reflected XSS.This issue affects MicroPayments: from n/a through <= 3.2.4.
medium 6.4 CVE-2024-13391 · published 2025-01-18
Stored cross-site scripting (XSS) in MicroPayments (2.9.29 and older)
- Affected
- 2.9.29 and older
- Fixed in
- 3.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MicroPayments – Fans Paysite: Paid Creator Subscriptions, Digital Assets, Tokens Wallet plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'videowhisper_content_upload_guest' shortcode in all versions up to, and including, 2.9.29 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 8.8 CVE-2022-27629 · published 2022-04-20
Cross-site request forgery (CSRF) in MicroPayments (older than 1.9.6)
- Affected
- older than 1.9.6
- Fixed in
- 1.9.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Cross-site request forgery (CSRF) vulnerability in 'MicroPayments - Paid Author Subscriptions, Content, Downloads, Membership' versions prior to 1.9.6 allows a remote unauthenticated attacker to hijack the authentication of an administrator and perform unintended operation via unspecified vectors.
Recent activity
- 2026-10-30 — latest release on wordpress.org (3.2.14).
- 2026-10-10 — Security issue disclosed (CVE-2026-107434), fixed in 3.2.10.
- 2025-06-28 — Cross-site request forgery (CSRF) disclosed (CVE-2025-5937), fixed in 3.2.1.
- 2025-03-28 — Stored cross-site scripting (XSS) disclosed (CVE-2025-31075), fixed in 2.9.30.
Get an email when MicroPayments has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MicroPayments (paid-membership) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by videowhisper (8 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/paid-membership (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/paid-membership"><img src="https://laskyr.com/plugins/paid-membership/badge.svg" alt="MicroPayments vulnerability status"></a>