Plugins · page-views-count · data as of 2026-11-04
Is Page View Count safe? Known vulnerabilities and latest version
- Latest version
- 2.9.2
- Last updated
- 2026-07-09
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Places an icon, all time views count and views today count at the bottom of posts, pages and custom post types on any WordPress website. — by Steve Truman
What to do
- Update to the latest version (2.9.2). Anything older than 2.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get page-views-count --field=version shows what you run; wp plugin update page-views-count updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2025-63034 · published 2025-12-09
Missing authorization check in Page View Count (2.9.0 and older)
- Affected
- 2.9.0 and older
- Fixed in
- 2.9.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Steve Truman Page View Count page-views-count allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Page View Count: from n/a through <= 2.9.0.
high 8.1 CVE-2025-2816 · published 2025-05-01
Missing authorization check in Page View Count (2.8.0 to 2.8.4)
- Affected
- 2.8.0 to 2.8.4
- Fixed in
- 2.8.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Page View Count plugin for WordPress is vulnerable to unauthorized modification of data that can lead to a denial of service due to a missing capability check on the yellow_message_dontshow() function in versions 2.8.0 to 2.8.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update option values to one on the WordPress site. This can be leveraged to update an option that would create an error on the site and deny service to legitimate users or be used to set some values to true such as registration.
medium 5.4 CVE-2023-0095 · published 2023-02-06
Stored cross-site scripting (XSS) in Page View Count (older than 2.6.1)
- Affected
- older than 2.6.1
- Fixed in
- 2.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Page View Count WordPress plugin before 2.6.1 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
medium 4.3 CVE-2022-40131 · published 2022-11-03
Cross-site request forgery (CSRF) in Page View Count (2.5.5 and older)
- Affected
- 2.5.5 and older
- Fixed in
- 2.5.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in a3rev Software Page View Count plugin <= 2.5.5 on WordPress allows an attacker to reset the plugin settings.
critical 9.8 CVE-2022-0434 · published 2022-03-07
SQL injection in Page View Count (older than 2.4.15)
- Affected
- older than 2.4.15
- Fixed in
- 2.4.15
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The Page View Count WordPress plugin before 2.4.15 does not sanitise and escape the post_ids parameter before using it in a SQL statement via a REST endpoint, available to both unauthenticated and authenticated users. As a result, unauthenticated attackers could perform SQL injection attacks
medium 5.4 CVE-2021-24509 · published 2021-08-09
Stored cross-site scripting (XSS) in Page View Count (older than 2.4.9)
- Affected
- older than 2.4.9
- Fixed in
- 2.4.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Page View Count WordPress plugin before 2.4.9 does not escape the postid parameter of pvc_stats shortcode, allowing users with a role as low as Contributor to perform Stored XSS attacks. A post made by a contributor would still have to be approved by an admin to have the XSS triggered in the frontend, however, higher privilege users, such as editor could exploit this without the need of approval, and even when the blog disallows the unfiltered_html capability.
Recent activity
- 2026-07-09 — latest release on wordpress.org (2.9.2).
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-63034), fixed in 2.9.1.
- 2025-05-01 — Missing authorization check disclosed (CVE-2025-2816), fixed in 2.8.5.
- 2023-02-06 — Stored cross-site scripting (XSS) disclosed (CVE-2023-0095), fixed in 2.6.1.
Get an email when Page View Count has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Page View Count (page-views-count) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Steve Truman (3 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/page-views-count (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/page-views-count"><img src="https://laskyr.com/plugins/page-views-count/badge.svg" alt="Page View Count vulnerability status"></a>