Skip to content
Laskyr

Plugins · page-or-post-clone · data as of 2026-11-04

Is Fast Page & Post Duplicator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.3)

As of 2026-11-04. 2 issues are on record for older versions.

Latest version
9.3
Last updated
2026-03-06
Active installs
50,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.7.11 · PHP 5.6+

Make a copy of posts and pages with just one click. — by carlosfazenda

What to do

  1. Update to the latest version (9.3). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get page-or-post-clone --field=version shows what you run; wp plugin update page-or-post-clone updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-2893 · published 2026-03-05

SQL injection in Fast Page & Post Duplicator (6.3 and older)

Affected
6.3 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Page and Post Clone plugin for WordPress is vulnerable to SQL Injection via the 'meta_key' parameter in the content_clone() function in all versions up to, and including, 6.3. This is due to insufficient escaping on the user-supplied meta_key value and insufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The injection is second-order: the malicious payload is stored as a post meta key and executed when the post is cloned.

NVD CVE-2026-2893Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-5942 · published 2024-06-29

Missing authorization check in Fast Page & Post Duplicator (6.0 and older)

Affected
6.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Page and Post Clone plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 6.0 via the 'content_clone' function due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Author-level access and above, to clone and read private posts.

NVD CVE-2024-5942Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fast Page & Post Duplicator vulnerability status badge
<a href="https://laskyr.com/plugins/page-or-post-clone"><img src="https://laskyr.com/plugins/page-or-post-clone/badge.svg" alt="Fast Page & Post Duplicator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit