Skip to content
Laskyr

Plugins · page-list · data as of 2026-11-04

Is Page-list safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.3)

As of 2026-11-04. 4 issues are on record for older versions; version 6.3 or newer fixes all of them that state a fix.

Latest version
6.3
Last updated
2026-05-29
Active installs
30,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8

[pagelist], [subpages], [siblings] and [pagelist_ext] shortcodes — by webvitalii

What to do

  1. Update to the latest version (6.3). Anything older than 6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get page-list --field=version shows what you run; wp plugin update page-list updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-9008 · published 2026-06-06

Missing authorization check in Page-list (6.2 and older)

Affected
6.2 and older
Fixed in
6.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Page-list plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 6.2. This is due to the pagelist_unqprfx_ext_shortcode() function (the [pagelist_ext] / [pagelistext] shortcode) accepting attacker-controlled post_status, post_type, and show_meta_key attributes and passing them directly into get_pages() and get_post_meta() with no capability check verifying that the rendering user is permitted to read the matched objects. When the current post has no child pages, the shortcode re-issues the query with child_of => 0, broadening it to every page on the site matching the supplied status/type. This makes it possible for authenticated attackers, with contributor-level access and above, to disclose the titles, body content/excerpts, and arbitrary post meta of unrelated private and draft pages by inserting the shortcode into a contributor-authored draft and previewing it.

NVD CVE-2026-9008Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-58030 · published 2025-09-22

Stored cross-site scripting (XSS) in Page-list (5.8 and older)

Affected
5.8 and older
Fixed in
5.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in webvitaly Page-list page-list allows Stored XSS.This issue affects Page-list: from n/a through <= 5.8.

NVD CVE-2025-58030Patchstack advisory

medium 6.5 CVE-2024-47382 · published 2024-10-05

Stored cross-site scripting (XSS) in Page-list (5.6 and older)

Affected
5.6 and older
Fixed in
5.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in webvitaly Page-list page-list allows Stored XSS.This issue affects Page-list: from n/a through <= 5.6.

NVD CVE-2024-47382Patchstack advisory

medium 5.4 CVE-2022-4485 · published 2023-01-23

Stored cross-site scripting (XSS) in Page-list (older than 5.3)

Affected
older than 5.3
Fixed in
5.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Page-list WordPress plugin before 5.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

NVD CVE-2022-4485WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Page-list vulnerability status badge
<a href="https://laskyr.com/plugins/page-list"><img src="https://laskyr.com/plugins/page-list/badge.svg" alt="Page-list vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit