Skip to content
Laskyr

Plugins · page-expire-popup · data as of 2026-11-04

Is Page Expire Popup/Redirection for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.0 or newer fixes all of them that state a fix.

Latest version
1.1
Last updated
2026-10-27
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Welcome to the Page Expire Popup An Awesome and Urgency Page Expire Popup or Redirect for WordPress. — by Vikas Ratudi

What to do

  1. Update to the latest version (1.1). Anything older than 1.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get page-expire-popup --field=version shows what you run; wp plugin update page-expire-popup updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-14153 · published 2026-01-06

SQL injection in Page Expire Popup/Redirection for WordPress (1.0 and older)

Affected
1.0 and older
Fixed in
1.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Page Expire Popup/Redirection for WordPress plugin for WordPress is vulnerable to time-based SQL Injection via the 'id' shortcode attribute in all versions up to, and including, 1.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Author-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-14153Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Page Expire Popup/Redirection for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/page-expire-popup"><img src="https://laskyr.com/plugins/page-expire-popup/badge.svg" alt="Page Expire Popup/Redirection for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit