Plugins · page-builder-wp · data as of 2026-11-04
Is WP Composer safe? Known vulnerabilities and latest version
- Latest version
- 1.0.7
- Last updated
- 2026-03-14
- Active installs
- 20+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.2+
The WP Composer Website Builder provides a drag and drop page builder, pixel perfect design, mobile responsive editing, and more. — by GhozyLab
What to do
- Update to the latest version (1.0.7). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get page-builder-wp --field=version shows what you run; wp plugin update page-builder-wp updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2422 · published 2026-09-19
Stored cross-site scripting (XSS) in WP Composer (1.0.5 and older)
- Affected
- 1.0.5 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Composer – The Easiest Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pbwp_raw_shortcode' shortcode in all versions up to, and including, 1.0.5. This is due to the shortcode handler decoding Base64-encoded content and outputting it directly without any sanitization or escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The Base64 encoding allows the payload to bypass WordPress's KSES content filtering at save time, since the encoded string contains no harmful HTML characters.
NVD CVE-2026-2422Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-03-14 — latest release on wordpress.org (1.0.7).
- 2026-09-19 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2422), fix version not stated.
Get an email when WP Composer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Composer (page-builder-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by GhozyLab (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/page-builder-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/page-builder-wp"><img src="https://laskyr.com/plugins/page-builder-wp/badge.svg" alt="WP Composer vulnerability status"></a>