Skip to content
Laskyr

Plugins · ownerrez · data as of 2026-11-04

Is OwnerRez safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.0)

As of 2026-11-04. 3 issues are on record for older versions; version 1.3.0 or newer fixes all of them that state a fix.

Latest version
1.3.0
Last updated
2026-08-24
Active installs
800+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11

The official WordPress plugin for the OwnerRez API. — by OwnerRez

What to do

  1. Update to the latest version (1.3.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ownerrez --field=version shows what you run; wp plugin update ownerrez updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.3 CVE-2026-81758 · published 2026-08-31

Missing authorization check in OwnerRez (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.3.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in OwnerRez API <= 1.2.6 versions.

NVD CVE-2026-81758Patchstack advisory

medium 6.5 CVE-2025-28957 · published 2025-07-04

Stored cross-site scripting (XSS) in OwnerRez (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in OwnerRez OwnerRez API ownerrez allows Stored XSS.This issue affects OwnerRez API: from n/a through <= 1.2.1.

NVD CVE-2025-28957Patchstack advisory

medium 4.3 CVE-2025-31814 · published 2025-04-01

Cross-site request forgery (CSRF) in OwnerRez (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in OwnerRez OwnerRez API ownerrez allows Cross Site Request Forgery.This issue affects OwnerRez API: from n/a through <= 1.2.0.

NVD CVE-2025-31814Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OwnerRez vulnerability status badge
<a href="https://laskyr.com/plugins/ownerrez"><img src="https://laskyr.com/plugins/ownerrez/badge.svg" alt="OwnerRez vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit