Skip to content
Laskyr

Plugins · otp-login · data as of 2026-11-04

Is Login with OTP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.7 or newer fixes all of them that state a fix.

Latest version
1.7
Last updated
2026-06-19
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.3+

Login with OTP for WordPress and WooCommerce. Secure your site by replacing static passwords with One Time Password (OTP) for login. — by WP-EXPERTS.IN

What to do

  1. Update to the latest version (1.7). Anything older than 1.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get otp-login --field=version shows what you run; wp plugin update otp-login updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-8760 · published 2026-05-27

Authentication bypass in Login with OTP (1.6 and older)

Affected
1.6 and older
Fixed in
1.7 *
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Wordfence
Details from the advisory

The Login with OTP plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 1.6. This is due to an incomplete fix for CVE-2024-11178: the rate-limit/lockout check added to `otpl_login_action()` was placed only inside the OTP-generation branch and is never evaluated on the OTP-validation branch, and the generated 6-digit OTP additionally has no expiration. This makes it possible for unauthenticated attackers to brute-force the 900,000-value OTP space for any user account (including administrators) and obtain a valid `wp_set_auth_cookie()` session, leading to full site compromise.

NVD CVE-2026-8760Wordfence advisorynvd.nist.govPlugin source

high 8.1 CVE-2024-11178 · published 2024-12-06

Authentication bypass in Login with OTP (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Login With OTP plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 1.4.2. This is due to the plugin generating too weak OTP, and there’s no attempt or time limit. This makes it possible for unauthenticated attackers to generate and brute force the 6-digit numeric OTP that makes it possible to log in as any existing user on the site, such as an administrator, if they have access to the email.

NVD CVE-2024-11178Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Login with OTP vulnerability status badge
<a href="https://laskyr.com/plugins/otp-login"><img src="https://laskyr.com/plugins/otp-login/badge.svg" alt="Login with OTP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit