Plugins · option-tree · data as of 2026-11-04
Is OptionTree safe? Known vulnerabilities and latest version
- Status
- Closed 2026-09-03
- Known issues on record
- 6
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate option-tree && wp plugin delete option-tree
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 6 record(s) do not state which versions are affected.
high 7.2 CVE-2026-66620 · published 2026-08-18
PHP object injection in OptionTree (2.7.3 and older)
- Affected
- 2.7.3 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Editor PHP Object Injection in OptionTree <= 2.7.3 versions.
critical 9.8 CVE-2019-15319 · published 2019-08-22
PHP object injection in OptionTree (older than 2.7.0)
- Affected
- older than 2.7.0
- Fixed in
- 2.7.0
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The option-tree plugin before 2.7.0 for WordPress has Object Injection by leveraging a valid nonce.
critical 9.8 CVE-2019-15320 · published 2019-08-22
PHP object injection in OptionTree (older than 2.7.3)
- Affected
- older than 2.7.3
- Fixed in
- 2.7.3
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The option-tree plugin before 2.7.3 for WordPress has Object Injection because the + character is mishandled.
critical 9.8 CVE-2019-15321 · published 2019-08-22
PHP object injection in OptionTree (older than 2.7.3)
- Affected
- older than 2.7.3
- Fixed in
- 2.7.3
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The option-tree plugin before 2.7.3 for WordPress has Object Injection because serialized classes are mishandled.
medium 6.1 CVE-2015-9320 · published 2019-08-20
Cross-site scripting (XSS) in OptionTree (older than 2.5.4)
- Affected
- older than 2.5.4
- Fixed in
- 2.5.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The option-tree plugin before 2.5.4 for WordPress has XSS related to add_query_arg.
medium 6.1 CVE-2016-10895 · published 2019-08-20
Cross-site scripting (XSS) in OptionTree (older than 2.6.0)
- Affected
- older than 2.6.0
- Fixed in
- 2.6.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The option-tree plugin before 2.6.0 for WordPress has XSS via an add_list_item or add_social_links AJAX request.
Recent activity
- 2026-09-03 — closed on wordpress.org (Security Issue).
- 2026-08-18 — PHP object injection disclosed (CVE-2026-66620), fix version not stated.
- 2019-08-22 — PHP object injection disclosed (CVE-2019-15319), fixed in 2.7.0.
- 2019-08-22 — PHP object injection disclosed (CVE-2019-15320), fixed in 2.7.3.
Get an email when OptionTree has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for OptionTree (option-tree) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: PHP object injection (4) · Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/option-tree (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/option-tree"><img src="https://laskyr.com/plugins/option-tree/badge.svg" alt="OptionTree vulnerability status"></a>