Skip to content
Laskyr

Plugins · optinmonster · data as of 2026-11-01

Is Popup Builder & Popup Maker for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.17.1)

As of 2026-11-01. 5 issues are on record for older versions; version 2.16.2 or newer fixes all of them that state a fix.

Latest version
2.17.1
Last updated
2026-08-14
Active installs
1+ million
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

🤩 Make popups & optin forms to get more email newsletter subscribers, leads, and sales - #1 most popular popup builder plugin! 🚀 — by Syed Balkhi

What to do

  1. Update to the latest version (2.17.1). Anything older than 2.16.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get optinmonster --field=version shows what you run; wp plugin update optinmonster updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2024-4045 · published 2024-05-25

Stored cross-site scripting (XSS) in Popup Builder & Popup Maker for WordPress (2.16.1 and older)

Affected
2.16.1 and older
Fixed in
2.16.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Popup Builder by OptinMonster – WordPress Popups for Optins, Email Newsletters and Lead Generation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘campaign_id’ parameter in versions up to, and including, 2.16.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4045Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-33691 · published 2024-04-26

Cross-site request forgery (CSRF) in Popup Builder & Popup Maker for WordPress (2.15.3 and older)

Affected
2.15.3 and older
Fixed in
2.16.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in OptinMonster Popup Builder Team OptinMonster.This issue affects OptinMonster: from n/a through 2.15.3.

NVD CVE-2024-33691Patchstack advisory

high 8.2 CVE-2021-39341 · published 2021-11-01

Information disclosure in Popup Builder & Popup Maker for WordPress (2.6.4 to 2.6.4)

Affected
2.6.4 to 2.6.4
Fixed in
2.13.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authorization validation via the logged_in_or_has_api_key function in the ~/OMAPI/RestApi.php file that can used to exploit inject malicious web scripts on sites with the plugin installed. This affects versions up to, and including, 2.6.4.

NVD CVE-2021-39341Wordfence advisoryWordfence advisoryPlugin source

medium 6.1 CVE-2021-39325 · published 2021-09-20

Reflected cross-site scripting (XSS) in Popup Builder & Popup Maker for WordPress (2.6.0 to 2.6.0)

Affected
2.6.0 to 2.6.0
Fixed in
2.13.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OptinMonster WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to insufficient input validation in the load_previews function found in the ~/OMAPI/Output.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 2.6.0.

NVD CVE-2021-39325Code change (fix)Wordfence advisory

medium 5.3 CVE-2016-10996 · published 2019-09-20

Missing authorization check in Popup Builder & Popup Maker for WordPress (older than 1.1.4.6)

Affected
older than 1.1.4.6
Fixed in
1.1.4.6
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The optinmonster plugin before 1.1.4.6 for WordPress has incorrect access control for shortcodes because of a nonce leak.

NVD CVE-2016-10996wordpress.orgpritect.net

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Popup Builder & Popup Maker for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/optinmonster"><img src="https://laskyr.com/plugins/optinmonster/badge.svg" alt="Popup Builder & Popup Maker for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit