Plugins · opening-hours · data as of 2026-11-04
Is We’re Open! safe? Known vulnerabilities and latest version
- Latest version
- 2.8
- Last updated
- 2026-10-28
- Active installs
- 5,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Opening hours for your business, a joy to manage and highly customizable. Conditional excerpts; conditional/replacement text; Structured Data for SEO. — by Noah Hearle
What to do
- Update to the latest version (2.8). Anything older than 2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get opening-hours --field=version shows what you run; wp plugin update opening-hours updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-112869 · published 2026-10-24
Reflected cross-site scripting (XSS) in We’re Open! (2.6 and older)
- Affected
- 2.6 and older
- Fixed in
- 2.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Noah Hearle We’re Open! opening-hours allows Reflected XSS.This issue affects We’re Open!: from n/a through 2.6.
medium 4.3 CVE-2023-25067 · published 2024-12-09
Missing authorization check in We’re Open! (1.45 and older)
- Affected
- 1.45 and older
- Fixed in
- 1.46
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Noah Hearle, Design Extreme We’re Open! allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects We’re Open!: from n/a through 1.45.
medium 4.8 CVE-2023-25964 · published 2023-06-13
Stored cross-site scripting (XSS) in We’re Open! (1.46 and older)
- Affected
- 1.46 and older
- Fixed in
- 1.47
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Noah Hearle, Design Extreme We’re Open! plugin <= 1.46 versions.
medium 4.8 CVE-2022-3139 · published 2022-10-17
Stored cross-site scripting (XSS) in We’re Open! (older than 1.42)
- Affected
- older than 1.42
- Fixed in
- 1.42
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The We’re Open! WordPress plugin before 1.42 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Recent activity
- 2026-10-28 — latest release on wordpress.org (2.8).
- 2026-10-24 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-112869), fixed in 2.7.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-25067), fixed in 1.46.
- 2023-06-13 — Stored cross-site scripting (XSS) disclosed (CVE-2023-25964), fixed in 1.47.
Get an email when We’re Open! has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for We’re Open! (opening-hours) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Noah Hearle (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/opening-hours (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/opening-hours"><img src="https://laskyr.com/plugins/opening-hours/badge.svg" alt="We’re Open! vulnerability status"></a>