Skip to content
Laskyr

Plugins · open-user-map · data as of 2026-11-04

Is Open User Map safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.56)

As of 2026-11-04. 6 issues are on record for older versions; version 1.4.51 or newer fixes all of them that state a fix.

Latest version
1.4.56
Last updated
2026-10-23
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Create custom interactive maps with free Leaflet-based styles, no Google Maps API key, frontend marker submissions, search and filters. — by 100plugins

What to do

  1. Update to the latest version (1.4.56). Anything older than 1.4.51 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get open-user-map --field=version shows what you run; wp plugin update open-user-map updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-84818 · published 2026-09-08

Cross-site scripting (XSS) in Open User Map (1.4.50 and older)

Affected
1.4.50 and older
Fixed in
1.4.51
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Open User Map <= 1.4.50 versions.

NVD CVE-2026-84818Patchstack advisory

medium 6.5 CVE-2026-66445 · published 2026-07-27

Cross-site scripting (XSS) in Open User Map (1.4.46 and older)

Affected
1.4.46 and older
Fixed in
1.4.47
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Open User Map <= 1.4.46 versions.

NVD CVE-2026-66445Patchstack advisory

medium 6.4 CVE-2026-15755 · published 2026-07-24

Stored cross-site scripting (XSS) in Open User Map (1.4.45 and older)

Affected
1.4.45 and older
Fixed in
1.4.46 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Open User Map – Interactive Leaflet Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode Attributes in all versions up to, and including, 1.4.45 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The attack does not require post publication; a Contributor submitting a post for pending review is sufficient, as the payload executes when an Administrator opens the pending-review preview.

NVD CVE-2026-15755Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-68002 · published 2026-02-20

Path traversal / file read in Open User Map (1.4.16 and older)

Affected
1.4.16 and older
Fixed in
1.4.17
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in 100plugins Open User Map open-user-map allows Path Traversal.This issue affects Open User Map: from n/a through <= 1.4.16.

NVD CVE-2025-68002Patchstack advisory

medium 6.5 CVE-2025-57953 · published 2025-09-22

Cross-site scripting (XSS) in Open User Map (1.4.14 and older)

Affected
1.4.14 and older
Fixed in
1.4.15
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in 100plugins Open User Map open-user-map allows DOM-Based XSS.This issue affects Open User Map: from n/a through <= 1.4.14.

NVD CVE-2025-57953Patchstack advisory

medium 4.8 CVE-2023-45056 · published 2023-10-18

Stored cross-site scripting (XSS) in Open User Map (1.3.26 and older)

Affected
1.3.26 and older
Fixed in
1.3.27
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in 100plugins Open User Map plugin <= 1.3.26 versions.

NVD CVE-2023-45056Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Open User Map vulnerability status badge
<a href="https://laskyr.com/plugins/open-user-map"><img src="https://laskyr.com/plugins/open-user-map/badge.svg" alt="Open User Map vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit