Plugins · oopspam-anti-spam · data as of 2026-11-04
Is oopspam Anti-Spam safe? Known vulnerabilities and latest version
- Latest version
- 1.2.88
- Last updated
- 2026-10-23
- Active installs
- 6,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Protect your forms from spam with 99.9% accuracy - no CAPTCHA, no JavaScript, no tracking. Trusted by 3.5M+ websites. — by oopspam Team
What to do
- Update to the latest version (1.2.88). Anything older than 1.2.63 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get oopspam-anti-spam --field=version shows what you run; wp plugin update oopspam-anti-spam updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-32544 · published 2026-03-25
Stored cross-site scripting (XSS) in oopspam Anti-Spam (1.2.62 and older)
- Affected
- 1.2.62 and older
- Fixed in
- 1.2.63
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in OOPSpam Team OOPSpam Anti-Spam oopspam-anti-spam allows Stored XSS.This issue affects OOPSpam Anti-Spam: from n/a through <= 1.2.62.
medium 5.3 CVE-2025-12094 · published 2025-10-31
Security issue in oopspam Anti-Spam (1.2.53 and older)
- Affected
- 1.2.53 and older
- Fixed in
- 1.2.54 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The OOPSpam Anti-Spam: Spam Protection for WordPress Forms & Comments (No CAPTCHA) plugin for WordPress is vulnerable to IP Header Spoofing in all versions up to, and including, 1.2.53. This is due to the plugin trusting client-controlled forwarded headers (such as CF-Connecting-IP, X-Forwarded-For, and others) without verifying that those headers originate from legitimate, trusted proxies. This makes it possible for unauthenticated attackers to spoof their IP address and bypass IP-based security controls, including blocked IP lists and rate limiting protections, by sending arbitrary HTTP headers with their requests.
NVD CVE-2025-12094Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2023-35913 · published 2023-07-11
Cross-site request forgery (CSRF) in oopspam Anti-Spam (1.1.44 and older)
- Affected
- 1.1.44 and older
- Fixed in
- 1.1.45
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in OOPSpam OOPSpam Anti-Spam plugin <= 1.1.44 versions.
medium 4.8 CVE-2023-22716 · published 2023-03-23
Cross-site scripting (XSS) in oopspam Anti-Spam (1.1.35 and older)
- Affected
- 1.1.35 and older
- Fixed in
- 1.1.36
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Cross-Site Scripting vulnerability in OOPSpam OOPSpam Anti-Spam plugin <= 1.1.35 versions.
Recent activity
- 2026-10-23 — latest release on wordpress.org (1.2.88).
- 2026-03-25 — Stored cross-site scripting (XSS) disclosed (CVE-2026-32544), fixed in 1.2.63.
- 2025-10-31 — Security issue disclosed (CVE-2025-12094), fixed in 1.2.54.
- 2023-07-11 — Cross-site request forgery (CSRF) disclosed (CVE-2023-35913), fixed in 1.1.45.
Get an email when oopspam Anti-Spam has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for oopspam Anti-Spam (oopspam-anti-spam) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/oopspam-anti-spam (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/oopspam-anti-spam"><img src="https://laskyr.com/plugins/oopspam-anti-spam/badge.svg" alt="oopspam Anti-Spam vulnerability status"></a>