Plugins · ooohboi-steroids-for-elementor · data as of 2026-11-04
Is OoohBoi Steroids for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 2.1.28
- Last updated
- 2026-06-10
- Active installs
- 40,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Boost your Elementor with some fresh and yet innovative options. — by Sagar Patel
What to do
- Update to the latest version (2.1.28). Anything older than 2.1.25 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ooohboi-steroids-for-elementor --field=version shows what you run; wp plugin update ooohboi-steroids-for-elementor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-3034 · published 2026-03-05
Stored cross-site scripting (XSS) in OoohBoi Steroids for Elementor (2.1.24 and older)
- Affected
- 2.1.24 and older
- Fixed in
- 2.1.25 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The OoohBoi Steroids for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the _ob_spacerat_link, _ob_bbad_link, and _ob_teleporter_link URL parameters in all versions up to, and including, 2.1.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user clicks on the injected element.
NVD CVE-2026-3034Wordfence advisorywordpress.orgPlugin source
medium 4.3 CVE-2023-1169 · published 2023-06-09
Missing authorization check in OoohBoi Steroids for Elementor (2.1.4 and older)
- Affected
- 2.1.4 and older
- Fixed in
- 2.1.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The OoohBoi Steroids for Elementor plugin for WordPress is vulnerable to missing authorization due to a missing capability check on the 'file_uploader_callback' function in versions up to, and including, 2.1.4. This makes it possible for subscriber-level attackers to upload image attachments to the site.
NVD CVE-2023-1169Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2023-0336 · published 2023-03-27
Cross-site request forgery (CSRF) in OoohBoi Steroids for Elementor (older than 2.1.5)
- Affected
- older than 2.1.5
- Fixed in
- 2.1.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The OoohBoi Steroids for Elementor WordPress plugin before 2.1.5 has CSRF and broken access control vulnerabilities which leads user with role as low as subscriber to delete attachment.
Recent activity
- 2026-06-10 — latest release on wordpress.org (2.1.28).
- 2026-03-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-3034), fixed in 2.1.25.
- 2023-06-09 — Missing authorization check disclosed (CVE-2023-1169), fixed in 2.1.5.
- 2023-03-27 — Cross-site request forgery (CSRF) disclosed (CVE-2023-0336), fixed in 2.1.5.
Get an email when OoohBoi Steroids for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for OoohBoi Steroids for Elementor (ooohboi-steroids-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ooohboi-steroids-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ooohboi-steroids-for-elementor"><img src="https://laskyr.com/plugins/ooohboi-steroids-for-elementor/badge.svg" alt="OoohBoi Steroids for Elementor vulnerability status"></a>