Plugins · online-accessibility · data as of 2026-11-04
Is Accessibility Suite by Ability, Inc safe? Known vulnerabilities and latest version
- Status
- Closed 2026-03-25
- Known issues on record
- 7
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate online-accessibility && wp plugin delete online-accessibility
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 7 record(s) do not state which versions are affected.
medium 6.5 CVE-2026-3773 · published 2026-04-16
SQL injection in Accessibility Suite by Ability, Inc (4.20 and older)
- Affected
- 4.20 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Accessibility Suite by Ability, Inc plugin for WordPress is vulnerable to SQL Injection via the 'scan_id' parameter in all versions up to, and including, 4.20. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
medium 5.4 CVE-2025-30636 · published 2025-06-06
Missing authorization check in Accessibility Suite by Ability, Inc (4.19 and older)
- Affected
- 4.19 and older
- Fixed in
- 4.20
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ability, Inc Accessibility Suite online-accessibility allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accessibility Suite: from n/a through <= 4.19.
high 8.5 CVE-2025-32650 · published 2025-04-11
SQL injection in Accessibility Suite by Ability, Inc (4.18 and older)
- Affected
- 4.18 and older
- Fixed in
- 4.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Ability, Inc Accessibility Suite online-accessibility allows SQL Injection.This issue affects Accessibility Suite: from n/a through <= 4.18.
medium 6.5 CVE-2025-32215 · published 2025-04-10
Stored cross-site scripting (XSS) in Accessibility Suite by Ability, Inc (4.18 and older)
- Affected
- 4.18 and older
- Fixed in
- 4.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Ability, Inc Accessibility Suite online-accessibility allows Stored XSS.This issue affects Accessibility Suite: from n/a through <= 4.18.
medium 6.3 CVE-2025-22698 · published 2025-02-14
Missing authorization check in Accessibility Suite by Ability, Inc (4.18 and older)
- Affected
- 4.18 and older
- Fixed in
- 4.19
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ability, Inc Accessibility Suite online-accessibility allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Accessibility Suite: from n/a through <= 4.18.
critical 9.8 CVE-2023-45830 · published 2023-11-06
SQL injection in Accessibility Suite by Ability, Inc (4.12 and older)
- Affected
- 4.12 and older
- Fixed in
- 4.13
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Online ADA Accessibility Suite by Online ADA allows SQL Injection.This issue affects Accessibility Suite by Online ADA: from n/a through 4.12.
critical 9.8 CVE-2022-47420 · published 2023-11-06
SQL injection in Accessibility Suite by Ability, Inc (4.12 and older)
- Affected
- 4.12 and older
- Fixed in
- 4.13
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Online ADA Accessibility Suite by Online ADA allows SQL Injection.This issue affects Accessibility Suite by Online ADA: from n/a through 4.12.
Recent activity
- 2026-03-25 — closed on wordpress.org (Security Issue).
- 2026-04-16 — SQL injection disclosed (CVE-2026-3773), fix version not stated.
- 2025-06-06 — Missing authorization check disclosed (CVE-2025-30636), fixed in 4.20.
- 2025-04-11 — SQL injection disclosed (CVE-2025-32650), fixed in 4.19.
Get an email when Accessibility Suite by Ability, Inc has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Accessibility Suite by Ability, Inc (online-accessibility) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (4) · Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/online-accessibility (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/online-accessibility"><img src="https://laskyr.com/plugins/online-accessibility/badge.svg" alt="Accessibility Suite by Ability, Inc vulnerability status"></a>