Plugins · onesignal-free-web-push-notifications · data as of 2026-11-04
Is OneSignal safe? Known vulnerabilities and latest version
- Latest version
- 3.9.4
- Last updated
- 2026-09-29
- Active installs
- 60,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Increase engagement and drive more repeat traffic to your WordPress site with push notifications. Now a WordPress VIP Gold Partner. — by OneSignal Push Notifications
What to do
- Update to the latest version (3.9.4). Anything older than 3.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get onesignal-free-web-push-notifications --field=version shows what you run; wp plugin update onesignal-free-web-push-notifications updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 3.1 CVE-2026-3155 · published 2026-04-16
Missing authorization check in OneSignal (3.8.0 and older)
- Affected
- 3.8.0 and older
- Fixed in
- 3.8.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The OneSignal – Web Push Notifications plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 3.8.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete OneSignal metadata for arbitrary posts.
medium 5.3 CVE-2025-13950 · published 2025-12-15
Missing authorization check in OneSignal (3.6.1 and older)
- Affected
- 3.6.1 and older
- Fixed in
- 3.6.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The OneSignal – Web Push Notifications plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the settings handling functionality in all versions up to, and including, 3.6.1. This is due to the plugin processing POST requests without verifying user capabilities or nonces. This makes it possible for unauthenticated attackers to overwrite the OneSignal App ID, REST API key, and notification behavior via direct POST requests.
medium 5.4 CVE-2019-15827 · published 2019-08-30
Cross-site scripting (XSS) in OneSignal (1.17.5 only)
- Affected
- 1.17.5 only
- Fixed in
- 1.17.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The onesignal-free-web-push-notifications plugin before 1.17.8 for WordPress has XSS via the subdomain parameter.
Recent activity
- 2026-09-29 — latest release on wordpress.org (3.9.4).
- 2026-04-16 — Missing authorization check disclosed (CVE-2026-3155), fixed in 3.8.1.
- 2025-12-15 — Missing authorization check disclosed (CVE-2025-13950), fixed in 3.6.2.
- 2019-08-30 — Cross-site scripting (XSS) disclosed (CVE-2019-15827), fixed in 1.17.6.
Get an email when OneSignal has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for OneSignal (onesignal-free-web-push-notifications) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/onesignal-free-web-push-notifications (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/onesignal-free-web-push-notifications"><img src="https://laskyr.com/plugins/onesignal-free-web-push-notifications/badge.svg" alt="OneSignal vulnerability status"></a>