Skip to content
Laskyr

Plugins · oneclick-whatsapp-order · data as of 2026-11-04

Is OneClick Chat to Order safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.0)

As of 2026-11-04. 5 issues are on record for older versions; version 1.1.0 or newer fixes all of them that state a fix.

Latest version
1.2.0
Last updated
2026-11-02
Active installs
30,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Transform your WooCommerce store with seamless WhatsApp integration. Enable customers to order products instantly via WhatsApp with enhanced features. — by Walter Pinem

What to do

  1. Update to the latest version (1.2.0). Anything older than 1.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get oneclick-whatsapp-order --field=version shows what you run; wp plugin update oneclick-whatsapp-order updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

low 2.7 CVE-2025-14270 · published 2026-02-19

Missing authorization check in OneClick Chat to Order (1.0.9 and older)

Affected
1.0.9 and older
Fixed in
1.1.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OneClick Chat to Order plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.0.9. This is due to the plugin not properly verifying that a user is authorized to perform an action in the wa_order_number_save_number_field function. This makes it possible for authenticated attackers, with Editor-level access and above, to modify WhatsApp phone numbers used by the plugin, redirecting customer orders and messages to attacker-controlled phone numbers.

NVD CVE-2025-14270Wordfence advisoryCode change (fix)wordpress.orgcwe.mitre.orgPlugin source

high 7.5 CVE-2025-13526 · published 2025-11-22

Missing authorization check in OneClick Chat to Order (1.0.8 and older)

Affected
1.0.8 and older
Fixed in
1.0.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OneClick Chat to Order plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.0.8 via the 'wa_order_thank_you_override' function due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to view sensitive customer information including names, email addresses, phone numbers, billing/shipping addresses, order contents, and payment methods by simply changing the order ID in the URL.

NVD CVE-2025-13526Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-29789 · published 2024-03-27

Stored cross-site scripting (XSS) in OneClick Chat to Order (1.0.5 and older)

Affected
1.0.5 and older
Fixed in
1.0.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Walter Pinem OneClick Chat to Order allows Stored XSS.This issue affects OneClick Chat to Order: from n/a through 1.0.5.

NVD CVE-2024-29789Patchstack advisory

medium 4.8 CVE-2023-47546 · published 2023-11-14

Stored cross-site scripting (XSS) in OneClick Chat to Order (1.0.4.2 and older)

Affected
1.0.4.2 and older
Fixed in
1.0.5 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Walter Pinem OneClick Chat to Order plugin <= 1.0.4.2 versions.

NVD CVE-2023-47546Patchstack advisory

medium 5.4 CVE-2022-4760 · published 2023-01-23

Stored cross-site scripting (XSS) in OneClick Chat to Order (older than 1.0.4.2)

Affected
older than 1.0.4.2
Fixed in
1.0.4.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The OneClick Chat to Order WordPress plugin before 1.0.4.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

NVD CVE-2022-4760WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OneClick Chat to Order vulnerability status badge
<a href="https://laskyr.com/plugins/oneclick-whatsapp-order"><img src="https://laskyr.com/plugins/oneclick-whatsapp-order/badge.svg" alt="OneClick Chat to Order vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit