Plugins · one-user-avatar · data as of 2026-11-04
Is One User Avatar safe? Known vulnerabilities and latest version
- Latest version
- 2.5.6
- Last updated
- 2026-08-21
- Active installs
- 100,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Use any image from your WordPress Media Library as a custom user avatar or user profile picture. Add your own Default Avatar. — by One Designs
What to do
- Update to the latest version (2.5.6). Anything older than 2.5.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get one-user-avatar --field=version shows what you run; wp plugin update one-user-avatar updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-18983 · published 2026-08-28
Stored cross-site scripting (XSS) in One User Avatar (2.5.4 and older)
- Affected
- 2.5.4 and older
- Fixed in
- 2.5.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The One User Avatar | User Profile Picture plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.5.4 via the wpua_action_process_option_update function. This is due to insufficient file type validation in wp_handle_upload() called without a MIME allow-list, with post-write validation relying on the attacker-controlled client-supplied Content-Type header rather than a server-derived type, and no cleanup of files that fail the check. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload files that may be executable, which makes remote code execution possible. in order to exploit this vulnerability an admin has to give subscribers permission to upload avatars. While PHP files and svg files are rejected, dxfp files are accepted.
NVD CVE-2026-18983Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2021-24672 · published 2021-10-18
Stored cross-site scripting (XSS) in One User Avatar (older than 2.3.7)
- Affected
- older than 2.3.7
- Fixed in
- 2.3.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The One User Avatar WordPress plugin before 2.3.7 does not escape the link and target attributes of its shortcode, allowing users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks
medium 6.5 CVE-2021-24675 · published 2021-10-18
Cross-site request forgery (CSRF) in One User Avatar (older than 2.3.7)
- Affected
- older than 2.3.7
- Fixed in
- 2.3.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The One User Avatar WordPress plugin before 2.3.7 does not check for CSRF when updating the Avatar in page where the [avatar_upload] shortcode is embed. As a result, attackers could make logged in user change their avatar via a CSRF attack
Recent activity
- 2026-08-21 — latest release on wordpress.org (2.5.6).
- 2026-08-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-18983), fixed in 2.5.5.
- 2021-10-18 — Stored cross-site scripting (XSS) disclosed (CVE-2021-24672), fixed in 2.3.7.
- 2021-10-18 — Cross-site request forgery (CSRF) disclosed (CVE-2021-24675), fixed in 2.3.7.
Get an email when One User Avatar has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for One User Avatar (one-user-avatar) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/one-user-avatar (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/one-user-avatar"><img src="https://laskyr.com/plugins/one-user-avatar/badge.svg" alt="One User Avatar vulnerability status"></a>