Skip to content
Laskyr

Plugins · one-click-demo-import · data as of 2026-11-01

Is One Click Demo Import safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.1)

As of 2026-11-01. 2 issues are on record for older versions; version 3.2.1 or newer fixes all of them that state a fix.

Latest version
3.4.1
Last updated
2026-04-22
Active installs
1+ million
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Import your demo content, widgets and theme settings with one click. Theme authors! Enable simple theme demo import for your users. — by Syed Balkhi

What to do

  1. Update to the latest version (3.4.1). Anything older than 3.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get one-click-demo-import --field=version shows what you run; wp plugin update one-click-demo-import updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2024-34433 · published 2024-05-14

PHP object injection in One Click Demo Import (3.2.0 and older)

Affected
3.2.0 and older
Fixed in
3.2.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Deserialization of Untrusted Data vulnerability in OCDI One Click Demo Import.This issue affects One Click Demo Import: from n/a through 3.2.0.

NVD CVE-2024-34433Patchstack advisory

high 7.2 CVE-2022-1008 · published 2022-04-11

Arbitrary file upload in One Click Demo Import (older than 3.1.0)

Affected
older than 3.1.0
Fixed in
3.1.0
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The One Click Demo Import WordPress plugin before 3.1.0 does not validate the imported file, allowing high privilege users such as admin to upload arbitrary files (such as PHP) even when FILE_MODS and FILE_EDIT are disallowed

NVD CVE-2022-1008WPScan advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
One Click Demo Import vulnerability status badge
<a href="https://laskyr.com/plugins/one-click-demo-import"><img src="https://laskyr.com/plugins/one-click-demo-import/badge.svg" alt="One Click Demo Import vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit