Plugins · omnipress · data as of 2026-11-04
Is Omnipress safe? Known vulnerabilities and latest version
- Latest version
- 1.6.7
- Last updated
- 2026-01-08
- Active installs
- 700+
- Known issues on record
- 6
- Unpatched in latest
- 2
- Tested up to WP
- 6.9.11 · PHP 7.4+
A powerful Gutenberg plugin with pre-built patterns, advanced blocks, and demo sites to speed up website creation using Full Site Editing. — by omnipress
What to do
- There is no fixed version yet. If you can live without Omnipress for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get omnipress --field=version shows what you run; wp plugin update omnipress updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 1.6.7 CVE-2026-25432 · published 2026-02-19
Stored cross-site scripting (XSS) in Omnipress (1.6.7 and older)
- Affected
- 1.6.7 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in omnipressteam Omnipress omnipress allows Stored XSS.This issue affects Omnipress: from n/a through <= 1.6.7.
high 7.5 affects latest 1.6.7 CVE-2026-24538 · published 2026-01-23
File inclusion in Omnipress (1.6.7 and older)
- Affected
- 1.6.7 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in omnipressteam Omnipress omnipress allows PHP Local File Inclusion.This issue affects Omnipress: from n/a through <= 1.6.7.
medium 6.4 CVE-2025-12163 · published 2025-12-05
Stored cross-site scripting (XSS) in Omnipress (1.6.5 and older)
- Affected
- 1.6.5 and older
- Fixed in
- 1.6.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Omnipress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2025-12163Wordfence advisoryCode change (fix)cwe.mitre.orgowasp.orgPlugin source
medium 6.5 CVE-2025-53276 · published 2025-06-27
Cross-site scripting (XSS) in Omnipress (1.6.4 and older)
- Affected
- 1.6.4 and older
- Fixed in
- 1.6.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in omnipressteam Omnipress omnipress allows DOM-Based XSS.This issue affects Omnipress: from n/a through <= 1.6.4.
medium 6.5 CVE-2024-13407 · published 2025-03-14
Information disclosure in Omnipress (1.5.4 and older)
- Affected
- 1.5.4 and older
- Fixed in
- 1.5.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Omnipress plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.5.4 via the megamenu block due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to.
high 7.1 CVE-2024-49278 · published 2024-10-17
Stored cross-site scripting (XSS) in Omnipress (1.4.3 and older)
- Affected
- 1.4.3 and older
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in omnipressteam Omnipress omnipress allows Stored XSS.This issue affects Omnipress: from n/a through <= 1.4.3.
Recent activity
- 2026-01-08 — latest release on wordpress.org (1.6.7).
- 2026-02-19 — Stored cross-site scripting (XSS) disclosed (CVE-2026-25432), no fix listed yet.
- 2026-01-23 — File inclusion disclosed (CVE-2026-24538), no fix listed yet.
- 2025-12-05 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12163), fixed in 1.6.6.
Get an email when Omnipress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Omnipress (omnipress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · File inclusion (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/omnipress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/omnipress"><img src="https://laskyr.com/plugins/omnipress/badge.svg" alt="Omnipress vulnerability status"></a>