Skip to content
Laskyr

Plugins · oliver-pos · data as of 2026-11-04

Is Oliver POS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.4)

As of 2026-11-04. 4 issues are on record for older versions; version 4.5.4 or newer fixes all of them that state a fix.

Latest version
4.9.4
Last updated
2026-09-24
Active installs
700+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.1+

WooCommerce POS for iPhone, iPad & Android. Tap to Pay, Stripe Terminal, offline mode, multi-outlet stock — every WooCommerce payment gateway. — by Oliver POS

What to do

  1. Update to the latest version (4.9.4). Anything older than 4.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get oliver-pos --field=version shows what you run; wp plugin update oliver-pos updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-6072 · published 2026-05-20

Authentication bypass in Oliver POS (2.4.2.6 and older)

Affected
2.4.2.6 and older
Fixed in
4.5.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Oliver POS – A WooCommerce Point of Sale (POS) plugin for WordPress is vulnerable to Authorization Bypass Through User-Controlled Key in all versions up to and including 2.4.2.6. The plugin protects its entire /wp-json/pos-bridge/* REST API namespace through the oliver_pos_rest_authentication() permission callback, which uses a loose PHP comparison (==) to compare the attacker-supplied 'OliverAuth' header value against the 'oliver_pos_authorization_token' option. On fresh installations where the admin has not yet completed the connection flow, this option is unset (get_option returns false). Due to PHP's type juggling, the loose comparison '0' == false evaluates to true, allowing an unauthenticated attacker to bypass authentication by sending 'OliverAuth: 0'. This grants full access to all POS API endpoints, enabling attackers to read user data (including administrator details), update user profiles (including email addresses), and delete non-admin users. An admin account email reset can lead to site takeover.

NVD CVE-2026-6072Wordfence advisoryPlugin source

critical 9.8 CVE-2024-13513 · published 2025-02-15

Information disclosure in Oliver POS (2.4.2.3 and older)

Affected
2.4.2.3 and older
Fixed in
4.5.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Oliver POS – A WooCommerce Point of Sale (POS) plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.4.2.3 via the logging functionality. This makes it possible for unauthenticated attackers to extract sensitive data including the plugin's clientToken, which in turn can be used to change user account information including emails and account type. This allows attackers to then change account passwords resulting in a complete site takeover. Version 2.4.2.3 disabled logging but left sites with existing log files vulnerable.

NVD CVE-2024-13513Wordfence advisoryCode change (fix)Plugin source

high 7.3 CVE-2024-0702 · published 2024-02-29

Missing authorization check in Oliver POS (2.4.2.0 and older)

Affected
2.4.2.0 and older
Fixed in
4.5.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Oliver POS – A WooCommerce Point of Sale (POS) plugin for WordPress is vulnerable to unauthorized access due to missing capability checks on several functions hooked via AJAX in the includes/class-pos-bridge-install.php file in all versions up to, and including, 2.4.2.1 This makes it possible for authenticated attackers, with subscriber-level access and above, to perform several unauthorized actions like deactivating the plugin, disconnecting the subscription, syncing the status and more.

NVD CVE-2024-0702Wordfence advisoryCode change (fix)Plugin source

medium 6.3 CVE-2024-1954 · published 2024-02-28

Cross-site request forgery (CSRF) in Oliver POS (2.4.1.8 and older)

Affected
2.4.1.8 and older
Fixed in
4.5.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Oliver POS – A WooCommerce Point of Sale (POS) plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.4.1.8. This is due to missing or incorrect nonce validation in the includes/class-pos-bridge-install.php file. This makes it possible for unauthenticated attackers to perform several unauthorized actions like deactivating the plugin, disconnecting the subscription, syncing the status and more via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-1954Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Oliver POS vulnerability status badge
<a href="https://laskyr.com/plugins/oliver-pos"><img src="https://laskyr.com/plugins/oliver-pos/badge.svg" alt="Oliver POS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit