Skip to content
Laskyr

Plugins · oik · data as of 2026-11-04

Is oik safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.16.0)

As of 2026-11-04. 8 issues are on record for older versions; version 4.16.0 or newer fixes all of them that state a fix.

Latest version
4.16.0
Last updated
2026-09-05
Active installs
2,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4

Over 80 advanced, powerful shortcodes, and 9 blocks for displaying the content of your WordPress website. — by bobbingwide

What to do

  1. Update to the latest version (4.16.0). Anything older than 4.16.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get oik --field=version shows what you run; wp plugin update oik updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-96819 · published 2026-09-30

Cross-site scripting (XSS) in oik (4.15.4 and older)

Affected
4.15.4 and older
Fixed in
4.16.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in oik <= 4.15.4 versions.

NVD CVE-2026-96819Patchstack advisory

medium 6.5 CVE-2025-67549 · published 2025-12-09

Cross-site scripting (XSS) in oik (4.15.3 and older)

Affected
4.15.3 and older
Fixed in
4.15.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bobbingwide oik oik allows DOM-Based XSS.This issue affects oik: from n/a through <= 4.15.3.

NVD CVE-2025-67549Patchstack advisory

high 7.1 CVE-2025-54670 · published 2025-08-20

Reflected cross-site scripting (XSS) in oik (4.15.2 and older)

Affected
4.15.2 and older
Fixed in
4.15.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bobbingwide oik oik allows Reflected XSS.This issue affects oik: from n/a through <= 4.15.2.

NVD CVE-2025-54670Patchstack advisory

medium 4.3 CVE-2025-54671 · published 2025-08-14

Cross-site request forgery (CSRF) in oik (4.15.2 and older)

Affected
4.15.2 and older
Fixed in
4.15.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in bobbingwide oik oik allows Cross Site Request Forgery.This issue affects oik: from n/a through <= 4.15.2.

NVD CVE-2025-54671Patchstack advisory

medium 5.3 CVE-2025-49241 · published 2025-06-06

Missing authorization check in oik (4.15.1 and older)

Affected
4.15.1 and older
Fixed in
4.15.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bobbingwide oik oik allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects oik: from n/a through <= 4.15.1.

NVD CVE-2025-49241Patchstack advisory

medium 4.3 CVE-2024-43356 · published 2024-08-26

Cross-site request forgery (CSRF) in oik (4.12.0 and older)

Affected
4.12.0 and older
Fixed in
4.12.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in bobbingwide.This issue affects oik: from n/a through 4.12.0.

NVD CVE-2024-43356Patchstack advisory

medium 6.4 CVE-2024-6391 · published 2024-07-09

Stored cross-site scripting (XSS) in oik (4.10.3 and older)

Affected
4.10.3 and older
Fixed in
4.12.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The oik plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's bw_button shortcode in all versions up to, and including, 4.10.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-6391Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2024-2256 · published 2024-03-14

Stored cross-site scripting (XSS) in oik (4.10.0 and older)

Affected
4.10.0 and older
Fixed in
4.10.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The oik plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes such as bw_contact_button and bw_button shortcodes in all versions up to, and including, 4.10.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2256Wordfence advisoryCode change (fix)oik-plugins.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
oik vulnerability status badge
<a href="https://laskyr.com/plugins/oik"><img src="https://laskyr.com/plugins/oik/badge.svg" alt="oik vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit