Plugins · official-statcounter-plugin-for-wordpress · data as of 2026-11-04
Is StatCounter safe? Known vulnerabilities and latest version
- Latest version
- 2.2.0
- Last updated
- 2026-08-19
- Active installs
- 70,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Real-time visitor stats, session replay and heatmaps for your WordPress site. See exactly how visitors use your site - and why they leave. — by StatCounter
What to do
- Update to the latest version (2.2.0). Anything older than 2.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get official-statcounter-plugin-for-wordpress --field=version shows what you run; wp plugin update official-statcounter-plugin-for-wordpress updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-57629 · published 2026-06-26
Cross-site scripting (XSS) in StatCounter (2.1.1 and older)
- Affected
- 2.1.1 and older
- Fixed in
- 2.1.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in StatCounter <= 2.1.1 versions.
medium 6.4 CVE-2026-6275 · published 2026-05-29
Stored cross-site scripting (XSS) in StatCounter (2.1.1 and older)
- Affected
- 2.1.1 and older
- Fixed in
- 2.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The StatCounter – Free Real Time Visitor Stats plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.1.1 This is due to insufficient output escaping on the post author's nickname in the statcounter_addToTags() function. The function is hooked to wp_head and fires on every single post page. It retrieves the post author's nickname via the_author_meta() and echoes it directly into a JavaScript double-quoted string context inside a <script> block without applying esc_js() or any equivalent JavaScript-context escaping. This makes it possible for authenticated attackers with Author-level access and above to inject arbitrary web scripts into pages that will execute whenever any user (including unauthenticated visitors) accesses a post authored by the attacker.
NVD CVE-2026-6275Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2025-13048 · published 2026-02-19
Stored cross-site scripting (XSS) in StatCounter (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The StatCounter – Free Real Time Visitor Stats plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the user's Nickname in all versions up to, and including, 2.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-13048Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-19 — latest release on wordpress.org (2.2.0).
- 2026-06-26 — Cross-site scripting (XSS) disclosed (CVE-2026-57629), fixed in 2.1.2.
- 2026-05-29 — Stored cross-site scripting (XSS) disclosed (CVE-2026-6275), fixed in 2.1.2.
- 2026-02-19 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13048), fixed in 2.1.1.
Get an email when StatCounter has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for StatCounter (official-statcounter-plugin-for-wordpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/official-statcounter-plugin-for-wordpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/official-statcounter-plugin-for-wordpress"><img src="https://laskyr.com/plugins/official-statcounter-plugin-for-wordpress/badge.svg" alt="StatCounter vulnerability status"></a>