Skip to content
Laskyr

Plugins · official-mailerlite-sign-up-forms · data as of 2026-11-04

Is MailerLite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.27)

As of 2026-11-04. 7 issues are on record for older versions; version 1.7.22 or newer fixes all of them that state a fix.

Latest version
1.7.27
Last updated
2026-10-27
Active installs
100,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.2.5+

Add newsletter signup forms to your WordPress site. Subscribers will be saved directly to your MailerLite account. Super easy to set up! — by MailerLite

What to do

  1. Update to the latest version (1.7.27). Anything older than 1.7.22 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get official-mailerlite-sign-up-forms --field=version shows what you run; wp plugin update official-mailerlite-sign-up-forms updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-3253 · published 2026-09-24

Missing authorization check in MailerLite (1.7.21 and older)

Affected
1.7.21 and older
Fixed in
1.7.22 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailerLite – Signup forms (official) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the forms() method of the AdminController class in all versions up to, and including, 1.7.21. This makes it possible for authenticated attackers, with Contributor-level access and above, to create or delete arbitrary signup forms.

NVD CVE-2026-3253Wordfence advisoryCode change (fix)

medium 4.3 CVE-2026-25420 · published 2026-02-19

Missing authorization check in MailerLite (1.7.18 and older)

Affected
1.7.18 and older
Fixed in
1.7.19
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in MailerLite MailerLite official-mailerlite-sign-up-forms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects MailerLite: from n/a through <= 1.7.18.

NVD CVE-2026-25420Patchstack advisory

medium 5.5 CVE-2025-13993 · published 2025-12-12

Stored cross-site scripting (XSS) in MailerLite (1.7.16 and older)

Affected
1.7.16 and older
Fixed in
1.7.17 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailerLite – Signup forms (official) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'form_description' and 'success_message' parameters in versions up to, and including, 1.7.16 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator access or higher, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13993Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2024-2797 · published 2024-05-02

Missing authorization check in MailerLite (1.7.6 and older)

Affected
1.7.6 and older
Fixed in
1.7.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailerLite – Signup forms (official) plugin for WordPress is vulnerable to unauthorized plugin setting changes due to a missing capability check on the toggleRolesAndPermissions and editAllowedRolesAndPermissions functions in all versions up to, and including, 1.7.6. This makes it possible for unauthenticated attackers to allow lower level users to modify forms.

NVD CVE-2024-2797Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-1386 · published 2024-05-02

Stored cross-site scripting (XSS) in MailerLite (1.5.0 to 1.7.6)

Affected
1.5.0 to 1.7.6
Fixed in
1.7.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MailerLite – Signup forms (official) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in versions 1.5.0 to 1.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-1386Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2022-33201 · published 2022-08-05

Cross-site request forgery (CSRF) in MailerLite (1.5.7 and older)

Affected
1.5.7 and older
Fixed in
1.5.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in MailerLite – Signup forms (official) plugin <= 1.5.7 at WordPress allows an attacker to change the API key.

NVD CVE-2022-33201Patchstack advisorywordpress.org

medium 6.1 CVE-2022-1604 · published 2022-06-13

Reflected cross-site scripting (XSS) in MailerLite (older than 1.5.4)

Affected
older than 1.5.4
Fixed in
1.5.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The MailerLite WordPress plugin before 1.5.4 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting

NVD CVE-2022-1604WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MailerLite vulnerability status badge
<a href="https://laskyr.com/plugins/official-mailerlite-sign-up-forms"><img src="https://laskyr.com/plugins/official-mailerlite-sign-up-forms/badge.svg" alt="MailerLite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit