Plugins · oauth2-provider · data as of 2026-11-04
Is WP OAuth Server (OAuth Authentication) safe? Known vulnerabilities and latest version
- Latest version
- 4.5.2
- Last updated
- 2026-09-24
- Active installs
- 3,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.0 · PHP 7.4+
Adds Authentication through OAuth 2. Provides the ability for Single Sign On for websites & Mobile Applications. — by Jayson T Cote
What to do
- Update to the latest version (4.5.2). Anything older than 4.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get oauth2-provider --field=version shows what you run; wp plugin update oauth2-provider updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-97288 · published 2026-09-30
Cross-site scripting (XSS) in WP OAuth Server (OAuth Authentication) (4.5.1 and older)
- Affected
- 4.5.1 and older
- Fixed in
- 4.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in OAuth Server <= 4.5.1 versions.
medium 6.1 CVE-2024-31253 · published 2024-04-10
Open redirect in WP OAuth Server (OAuth Authentication) (4.3.3 and older)
- Affected
- 4.3.3 and older
- Fixed in
- 4.4.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in WP OAuth Server OAuth Server.This issue affects OAuth Server: from n/a through 4.3.3.
medium 4.3 CVE-2022-3894 · published 2023-03-20
Cross-site request forgery (CSRF) in WP OAuth Server (OAuth Authentication) (older than 4.2.5)
- Affected
- older than 4.2.5
- Fixed in
- 4.2.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.2.5 does not have CSRF check when deleting a client, and does not ensure that the object to be deleted is actually a client, which could allow attackers to make a logged in admin delete arbitrary client and post via a CSRF attack.
medium 4.3 CVE-2022-4148 · published 2023-03-20
Cross-site request forgery (CSRF) in WP OAuth Server (OAuth Authentication) (older than 4.3.0)
- Affected
- older than 4.3.0
- Fixed in
- 4.3.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.3.0 has a flawed CSRF and authorisation check when deleting a client, which could allow any authenticated users, such as subscriber to delete arbitrary client.
medium 4.8 CVE-2022-3892 · published 2022-12-05
Stored cross-site scripting (XSS) in WP OAuth Server (OAuth Authentication) (older than 4.2.2)
- Affected
- older than 4.2.2
- Fixed in
- 4.2.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.2.2 does not sanitize and escape Client IDs, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
medium 6.5 CVE-2022-3926 · published 2022-12-05
Cross-site request forgery (CSRF) in WP OAuth Server (OAuth Authentication) (older than 3.4.2)
- Affected
- older than 3.4.2
- Fixed in
- 3.4.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP OAuth Server (OAuth Authentication) WordPress plugin before 3.4.2 does not have CSRF check when regenerating secrets, which could allow attackers to make logged in admins regenerate the secret of an arbitrary client given they know the client ID
critical 9.8 CVE-2015-9435 · published 2019-09-26
Weak randomness in WP OAuth Server (OAuth Authentication) (older than 3.1.5)
- Affected
- older than 3.1.5
- Fixed in
- 3.1.5
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The oauth2-provider plugin before 3.1.5 for WordPress has incorrect generation of random numbers.
Recent activity
- 2026-09-24 — latest release on wordpress.org (4.5.2).
- 2026-09-30 — Cross-site scripting (XSS) disclosed (CVE-2026-97288), fixed in 4.5.2.
- 2024-04-10 — Open redirect disclosed (CVE-2024-31253), fixed in 4.4.0.
- 2023-03-20 — Cross-site request forgery (CSRF) disclosed (CVE-2022-3894), fixed in 4.2.5.
Get an email when WP OAuth Server (OAuth Authentication) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP OAuth Server (OAuth Authentication) (oauth2-provider) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (3) · Cross-site scripting (XSS) (2) · Open redirect (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/oauth2-provider (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/oauth2-provider"><img src="https://laskyr.com/plugins/oauth2-provider/badge.svg" alt="WP OAuth Server (OAuth Authentication) vulnerability status"></a>