Plugins · nova-blocks · data as of 2026-11-04
Is Nova Blocks by Pixelgrade safe? Known vulnerabilities and latest version
- Latest version
- 2.7.2
- Last updated
- 2026-09-28
- Active installs
- 800+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A collection of distinctive Gutenberg blocks, committed to making your site shine like a newborn star. — by pixelgrade
What to do
- Update to the latest version (2.7.2). Anything older than 2.1.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get nova-blocks --field=version shows what you run; wp plugin update nova-blocks updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-24528 · published 2026-01-23
Cross-site scripting (XSS) in Nova Blocks by Pixelgrade (2.1.9 and older)
- Affected
- 2.1.9 and older
- Fixed in
- 2.1.10
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pixelgrade Nova Blocks nova-blocks allows DOM-Based XSS.This issue affects Nova Blocks: from n/a through <= 2.1.9.
medium 6.5 CVE-2025-31819 · published 2025-04-01
Cross-site scripting (XSS) in Nova Blocks by Pixelgrade (2.1.8 and older)
- Affected
- 2.1.8 and older
- Fixed in
- 2.1.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pixelgrade Nova Blocks nova-blocks.This issue affects Nova Blocks: from n/a through <= 2.1.8.
medium 5.4 CVE-2024-8241 · published 2024-09-10
Stored cross-site scripting (XSS) in Nova Blocks by Pixelgrade (2.1.7 and older)
- Affected
- 2.1.7 and older
- Fixed in
- 2.1.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Nova Blocks by Pixelgrade plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'align' attribute of the 'wp:separator' Gutenberg block in all versions up to, and including, 2.1.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-8241Wordfence advisoryCode change (fix)wordpress.orggithub.com
Recent activity
- 2026-09-28 — latest release on wordpress.org (2.7.2).
- 2026-01-23 — Cross-site scripting (XSS) disclosed (CVE-2026-24528), fixed in 2.1.10.
- 2025-04-01 — Cross-site scripting (XSS) disclosed (CVE-2025-31819), fixed in 2.1.9.
- 2024-09-10 — Stored cross-site scripting (XSS) disclosed (CVE-2024-8241), fixed in 2.1.8.
Get an email when Nova Blocks by Pixelgrade has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Nova Blocks by Pixelgrade (nova-blocks) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by pixelgrade (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/nova-blocks (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/nova-blocks"><img src="https://laskyr.com/plugins/nova-blocks/badge.svg" alt="Nova Blocks by Pixelgrade vulnerability status"></a>