Plugins · notify-odoo · data as of 2026-11-04
Is Notify Odoo safe? Known vulnerabilities and latest version
- Latest version
- 1.0.2
- Last updated
- 2026-10-22
- Active installs
- 80+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Notifies Odoo about a new order on WooCommerce. — by Pektsekye
What to do
- Update to the latest version (1.0.2). Anything older than 1.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get notify-odoo --field=version shows what you run; wp plugin update notify-odoo updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-8425 · published 2026-05-15
Cross-site request forgery (CSRF) in Notify Odoo (1.0.1 and older)
- Affected
- 1.0.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Notify Odoo plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.1. This is due to missing or incorrect nonce validation on the _updateSettings function. This makes it possible for unauthenticated attackers to change the Notify Odoo URL to an attacker-controlled URL and modify notification, tracking image, and allowed IP address settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2026-8425Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2024-56299 · published 2025-01-07
Stored cross-site scripting (XSS) in Notify Odoo (1.0.0 and older)
- Affected
- 1.0.0 and older
- Fixed in
- 1.0.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Pektsekye Notify Odoo notify-odoo allows Stored XSS.This issue affects Notify Odoo: from n/a through <= 1.0.0.
Recent activity
- 2026-10-22 — latest release on wordpress.org (1.0.2).
- 2026-05-15 — Cross-site request forgery (CSRF) disclosed (CVE-2026-8425), fix version not stated.
- 2025-01-07 — Stored cross-site scripting (XSS) disclosed (CVE-2024-56299), fixed in 1.0.1.
Get an email when Notify Odoo has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Notify Odoo (notify-odoo) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/notify-odoo (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/notify-odoo"><img src="https://laskyr.com/plugins/notify-odoo/badge.svg" alt="Notify Odoo vulnerability status"></a>